View Issue Details

IDProjectCategoryView StatusLast Update
0001325XdebugFeature/Change requestpublic2016-07-05 14:32
ReporterfelixfbeckerAssigned Toderick 
PrioritylowSeveritytweakReproducibilityalways
Status resolvedResolutionwon't fix 
Product Version 
Target VersionFixed in Version 
Summary0001325: Use semver-compatible version numbers for pre-releases
DescriptionCurrently, the RC versions report a version like "2.4.0RC3". Semver specifies that a pre-release tag must be seperated with a hyphen, like "2.4.0-RC3", see http://semver.org/#spec-item-9

This imposes problems because I try to parse the version number in my debug extension as a semver version to find out if I can enable specific features, but the release candidate versions throw errors when trying to parse them. Please use semver-compatible pre-release tags in the future.
TagsNo tags attached.
Operating System
PHP Version7.0.5-7.0.9

Activities

derick

2016-07-05 14:32

administrator   ~0003639

https://wiki.php.net/rfc/peclversioning/solution2 says

"Note that the PEAR installer cannot recognize hyphens in a package version string"

And the PEAR documentation (used for installing packages) has examples at:
http://pear.php.net/group/docs/20040226-vn.php

Issue History

Date Modified Username Field Change
2016-07-05 12:51 felixfbecker New Issue
2016-07-05 14:32 derick Note Added: 0003639
2016-07-05 14:32 derick Status new => resolved
2016-07-05 14:32 derick Resolution open => won't fix
2016-07-05 14:32 derick Assigned To => derick