View Issue Details

IDProjectCategoryView StatusLast Update
0001330XdebugInstallationpublic2016-07-31 12:30
ReporterfwendtAssigned Toderick 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionno change required 
PlatformPC x86OSUbuntu LinuxOS Version12.04
Product Version2.4.0 
Target VersionFixed in Version 
Summary0001330: Zend Engine API differs and install from src compile is failing for 7.0.8
DescriptionAfter have installed Apache 2.4.23 with PHP 7.0.8, I could not install Xdebug on this environment.

Apache error log points: Xdebug requires Zend Engine API version 220100525.
The Zend Engine API version 320151012 which is installed, is newer.
Contact Derick Rethans at http://xdebug.org/docs/faq#api for a later version of Xdebug.

Compiling from sources, runnig phpize and loading extension with "zend_extension" at "php.ini" file.
Steps To ReproduceGet the sources from Apache 2.4.23, PHP 7.0.8 and Xdebug 2.4.0 and try to make it run.
Additional InformationPHP info page does not load xdebug extension, and Apache error log points a entry.
TagsNo tags attached.
Operating System
PHP Version7.0.5-7.0.9

Activities

derick

2016-07-31 12:30

administrator   ~0003659

This is not a bug, but something you do wrong locally. Likely building against the wrong headers. Please write to our support list: https://xdebug.org/support.php for help.

Issue History

Date Modified Username Field Change
2016-07-22 20:03 fwendt New Issue
2016-07-31 12:30 derick Note Added: 0003659
2016-07-31 12:30 derick Status new => resolved
2016-07-31 12:30 derick Resolution open => no change required
2016-07-31 12:30 derick Assigned To => derick