View Issue Details

IDProjectCategoryView StatusLast Update
0001340XdebugUsage problems (Wrong Results)public2016-12-11 23:46
Reporterlepczynski-sAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformPCOSWindowsOS Version10
Product Version2.4.0 
Target VersionFixed in Version 
Summary0001340: Xdebug (somehow) affects cross-origin headers
DescriptionIt's more strange than it seems. It's not that CORS headers don't work when Xdebug is enabled. It's the other way around!

CORS headers are present in the respons _only_ when Xdebug is enabled in php.ini.

On the other hand when Xdebug is _disabled_ CORS headers are working _only_ for OPTIONS preflight and for GET methods, as far as i can tell.

So to be clear on that:

Xdebug ENABLED: CORS headers works perfect.
Xdebug DISABLED: Only OPTIONS preflight and GET requests, for any other resources browser throws: `No 'Access-Control-Allow-Origin' header is present on the requested resource.` error.
Steps To ReproduceHere's what i did:

* created fresh lumen framework project via composer
* installed and configured jwt-auth & jwt-auth-guard (probably not relevant)
* installed and configured laravel-cors (for per route CORS configuration)

And that's it. Nothing fancy, everything according to the official docs.

* set up any post route in the application
* and tried to make some XMLHttpRequest to this post route from the browser

Effects:

* When Xdebug was disabled i was getting `No 'Access-Control-Allow-Origin'` errors no matter what i tried to do with the configuration.

* When Xdebug was enabled it `just worked` without any hacks.
Additional InformationEnvironment:

* Windows 10
* Wampserver 3.0.4 x64
* Apache 2.4.18
* PHP 5.6.19
* Xdebug 2.4.0-5.6-vc11-x86_64
TagsNo tags attached.
Operating SystemWindows 10
PHP Version5.6.15-5.6.19

Activities

derick

2016-08-30 09:23

administrator   ~0003695

Xdebug shouldn't interfere with headers. And with this little information, I have no idea how to debug this. I can't be debugging all of Laravel. Please provide a short reproducible case that demonstrates this problem. If you do that, I can have a look.

derick

2016-11-16 21:22

administrator   ~0003754

Ping?

derick

2016-12-11 23:46

administrator   ~0004011

Can't reproduce, and the requested feedback was not provided.

Issue History

Date Modified Username Field Change
2016-08-27 12:42 lepczynski-s New Issue
2016-08-30 09:23 derick Note Added: 0003695
2016-08-30 09:23 derick Assigned To => derick
2016-08-30 09:23 derick Status new => feedback
2016-11-16 21:22 derick Note Added: 0003754
2016-12-11 23:46 derick Note Added: 0004011
2016-12-11 23:46 derick Status feedback => resolved
2016-12-11 23:46 derick Resolution open => unable to reproduce