View Issue Details

IDProjectCategoryView StatusLast Update
0001341XdebugUsage problems (Wrong Results)public2016-10-17 10:43
ReporteredroidAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformLinuxOSUbuntuOS Version16.04.1 LTS
Product Version2.4.0 
Target VersionFixed in Version 
Summary0001341: Crash when array key contains \0 symbol
DescriptionCrash when meet \0 symbol in array key of type string. For example:
$prop = ['' . "\0" . '*' . "\0" . 'id' => 1];
TagsNo tags attached.
Operating System
PHP Version7.0.5-7.0.9

Activities

derick

2016-08-30 10:59

administrator   ~0003696

When do you see this bug?

Is it while var_dump()ing?

How does it "crash"?

What is the output that you get?

What is the outcome that you expected?

Does this happen when remote debugging? If this is the case, can you please follow the instructions at https://xdebug.org/support.php#remote to provide all the information that I need to reproduce this?

derick

2016-09-08 18:28

administrator   ~0003700

Could you please provide the information I asked for?

derick

2016-10-17 10:43

administrator   ~0003722

Can't reproduce this, and no extra information provided when I asked for it.

Issue History

Date Modified Username Field Change
2016-08-30 10:50 edroid New Issue
2016-08-30 10:59 derick Note Added: 0003696
2016-08-30 10:59 derick Assigned To => derick
2016-08-30 10:59 derick Status new => feedback
2016-09-08 18:28 derick Note Added: 0003700
2016-10-17 10:43 derick Note Added: 0003722
2016-10-17 10:43 derick Status feedback => resolved
2016-10-17 10:43 derick Resolution open => unable to reproduce