View Issue Details

IDProjectCategoryView StatusLast Update
0001356XdebugUsage problems (Wrong Results)public2017-01-04 10:31
ReporterGinoPaneAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformMacbook ProOSmacOsOS Version10.12
Product Version2.4.1 
Target VersionFixed in Version 
Summary0001356: Code coverage show 0 on PHP7.0.12 + xdebug 2.4.1
DescriptionEverything is described in github thread:
https://github.com/sebastianbergmann/php-code-coverage/issues/475
But after debugging of CodeCoverage files I've found out, that xdebug driver returns "-1" for all lines in my files.
TagsNo tags attached.
Operating SystemmacOs Sierra
PHP Version7.0.10-7.0.14

Activities

derick

2016-12-04 16:29

administrator   ~0003915

In order for me to look at this, I need a self-contained and reproducible case as part of this bug tracker. There are so many comments on the issues on php-code-coverage that I simply don't understand what people are saying. A fully concise description here, would improve this immensely.

derick

2017-01-03 18:46

administrator   ~0004123

Ping?

GinoPane

2017-01-03 19:45

reporter   ~0004143

Sorry for disappearing. More deep research was made and it became clear, that the problem was with php-code-coverage itself, not with xdebug. So the issue can be closed.

derick

2017-01-04 10:31

administrator   ~0004152

OK. Perfect. Let me close this then.

Issue History

Date Modified Username Field Change
2016-10-21 09:03 GinoPane New Issue
2016-12-04 16:29 derick Note Added: 0003915
2016-12-04 16:29 derick Assigned To => derick
2016-12-04 16:29 derick Status new => feedback
2017-01-03 18:46 derick Note Added: 0004123
2017-01-03 19:45 GinoPane Note Added: 0004143
2017-01-03 19:45 GinoPane Status feedback => assigned
2017-01-04 10:31 derick Note Added: 0004152
2017-01-04 10:31 derick Status assigned => resolved
2017-01-04 10:31 derick Resolution open => no change required