View Issue Details

IDProjectCategoryView StatusLast Update
0001367XdebugRemote Debuggingpublic2016-12-19 11:59
ReporterpalmicAssigned Toderick 
PriorityhighSeveritycrashReproducibilityhave not tried
Status resolvedResolutionno change required 
PlatformAppleOSOs X El CapitanOS Version10.11.6
Product Version2.5.0RC1 
Target VersionFixed in Version 
Summary0001367: debugger SIGSEGV crashes on breakpoint on certain cases with amqp lib
DescriptionI've tried all versions of xdebug available for php71 from github with the same result
i've tried both phpstorm's stable and EAP with the same result, they've reported its xdebug Issue: https://youtrack.jetbrains.com/issue/WI-34047#comment=27-1750977
You can even find phpstorm log there attached.
Steps To Reproduce1. install rabbitMQ if you have no available at your disposal (https://www.rabbitmq.com/install-homebrew.html)
2. ensure you have php 7.1 with xdebug installed ("brew install php71 php71-xdebug")
3. install amqp lib ("brew install php71-amqp")
4. check amqp in "php -i"
5. git clone git@github.com:palmic/php-brake-debugger.git
6. open this project in phpstorm
7. change amqp connection in index.php if you are not using your local one
8. open index.php and set breakpoint on line with "$this->callMe(); // set breakpoint here, it should end by SIGSEGV after 3 breaks"
9. doublecheck you have php7.1 runner set in phpstorm and start debugging
9.1 if you cannot connect to your local rabbitmq run "/usr/local/sbin/rabbitmq-server" in special terminal window and check log path (/usr/local/var/log/rabbitmq/rabbit@localhost.log)
9.2 open log and find "started TCP Listener on", there you'll see which port you are running - set this to index.php as host: localhost, port: $port
10. after debugger breaks at that line resume debugger (F9)
11. at second break again resume (F9)
12. at third break it should crash with SIGSEGV
Additional InformationIf you check git project history, you'll find there is commit which don't crash, which is very strange, because there is only 3 line of code before breakpoint which shouldn't influent the break.
TagsNo tags attached.
Operating System
PHP Version7.1-dev

Activities

derick

2016-12-04 17:06

administrator   ~0003922

Could you provide a GDB backtrace please, as is described at https://bugs.php.net/bugs-generating-backtrace.php

palmic

2016-12-19 11:38

reporter   ~0004084

As it forced me to completely reinstall php with relevant extensions (xdebug, amqp) in current versions in debug mode, i found it already fixed somehow...

Then i completely reinstalled all php in brew with standard packages settings and its really fixed even in public packages revisions.

Please close this ticket.

Thank you for your time.

derick

2016-12-19 11:59

administrator   ~0004085

Great! Thanks for checking this.

Issue History

Date Modified Username Field Change
2016-11-25 12:12 palmic New Issue
2016-12-04 17:06 derick Note Added: 0003922
2016-12-04 17:06 derick Assigned To => derick
2016-12-04 17:06 derick Status new => feedback
2016-12-19 11:38 palmic Note Added: 0004084
2016-12-19 11:38 palmic Status feedback => assigned
2016-12-19 11:59 derick Note Added: 0004085
2016-12-19 11:59 derick Status assigned => resolved
2016-12-19 11:59 derick Resolution open => no change required