View Issue Details

IDProjectCategoryView StatusLast Update
0001389XdebugFeature/Change requestpublic2019-05-07 11:09
ReporterLanaZemAssigned Toderick 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionduplicate 
Product Version 
Target Version2.8.0devFixed in Version 
Summary0001389: Support 'breakpoint_resolved' notification
Descriptionhttps://github.com/derickr/dbgp/pull/11/files

It's not always possible to resolve breakpoint. It would be much more convenient not only show breakpoint as invalid but also resolve it to the correct line.
It will save users a lot of time because they won't need to search for it manually.
Steps To Reproduce1) Create a file with the following code
'
<?php

$a = array( // line #1
    1 => "first", // line 0000002
    2 => "second",
);
'

2) Set breakpoint only on line #1
3) Start debugger session

Expected:
Breakpoint #1 is resolved to line #1 and execution halts there.

Actual:
Execution doesn't halt.
Additional InformationCorresponding PhpStorm issues:
https://youtrack.jetbrains.com/issue/WI-4721
https://youtrack.jetbrains.com/issue/WI-2191
https://youtrack.jetbrains.com/issue/WI-2898
https://youtrack.jetbrains.com/issue/WI-6916
TagsNo tags attached.
Operating System
PHP Version7.1.0-7.1.4

Relationships

duplicate of 0001388 closedderick Support 'resolved' flag for breakpoints 

Activities

derick

2018-12-18 11:13

administrator   ~0004775

Punting this to 3.0, as 2.7 needs to come out soon with PHP 7.3 support.

derick

2019-04-14 17:15

administrator   ~0004998

This is really a duplicate of 0001388, as these two features go hand in hand.

Issue History

Date Modified Username Field Change
2017-01-11 17:44 LanaZem New Issue
2017-01-14 11:28 derick Status new => confirmed
2017-01-14 11:28 derick Target Version => 2.6.0dev
2017-11-18 14:14 derick Target Version 2.6.0dev => 2.7.0dev
2018-12-18 11:13 derick Note Added: 0004775
2018-12-18 11:13 derick Target Version 2.7.0dev => 3.0.0dev
2019-04-14 17:15 derick Assigned To => derick
2019-04-14 17:15 derick Status confirmed => resolved
2019-04-14 17:15 derick Resolution open => duplicate
2019-04-14 17:15 derick Note Added: 0004998
2019-04-14 17:15 derick Relationship added duplicate of 0001388
2019-05-07 11:09 derick Target Version 3.0.0dev => 2.8.0dev