View Issue Details

IDProjectCategoryView StatusLast Update
0001399XdebugCode Coveragepublic2017-02-19 23:17
ReporterdakusanAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.5.0RC1 
Target VersionFixed in Version 
Summary0001399: Dynamic variables not reported
DescriptionWhen variables are created dynamically within a function they do not show up in watch windows until they have been referenced.
Steps To ReproduceExample Code:
function test()
{
    extract(Array("a"=>1)); //$a never shows up in the watch window
    $b = 22;
    $c = 12;
}
test();
Additional InformationI'm actually using your latest compile from github.

This has been confirmed in php 5.6 and 7.1.2 (latest version).
TagsNo tags attached.
Operating SystemWindows 7
PHP Version7.1.0-7.1.4

Relationships

duplicate of 0000546 acknowledged None of debug clients are able to see variables produced by php "extract()" function 

Activities

derick

2017-02-19 23:17

administrator   ~0004218

This is a duplicate of 0000546, so I am closing this issue.

Issue History

Date Modified Username Field Change
2017-02-19 20:56 dakusan New Issue
2017-02-19 23:17 derick Note Added: 0004218
2017-02-19 23:17 derick Relationship added duplicate of 0000546
2017-02-19 23:17 derick Status new => resolved
2017-02-19 23:17 derick Resolution open => duplicate
2017-02-19 23:17 derick Assigned To => derick