View Issue Details

IDProjectCategoryView StatusLast Update
0001418XdebugInstallationpublic2017-04-17 17:26
ReporterDambulAssigned Toderick 
PriorityhighSeverityblockReproducibilityalways
Status resolvedResolutionno change required 
PlatformEC2 x64OSAMI LinuxOS Version
Product Version2.5.1 
Target VersionFixed in Version 
Summary0001418: Unable to get Xdebug working
DescriptionI followed all the steps that are suggested here (https://xdebug.org/wizard.php).

1. Download xdebug-2.5.1.tgz
2. Unpack the downloaded file with tar -xvzf xdebug-2.5.1.tgz
3. Run: cd xdebug-2.5.1
4. Run: phpize
5. Run: ./configure
6. Run: make
7. Run: cp modules/xdebug.so /usr/lib64/php-zts/7.0/modules
8. Edit /etc/php.ini and add the line
zend_extension = /usr/lib64/php-zts/7.0/modules/xdebug.so
9. Restart the webserver

I'm getting error in Apache logs.
Failed loading /usr/lib64/php/7.0/modules/xdebug.so: /usr/lib64/php-zts/7.0/modules/xdebug.so: undefined symbol: compiler_globals
Additional InformationI checked phpize - it is correct one.
Apache configured for mpm-event.
TagsNo tags attached.
Operating SystemAMI Linux
PHP Version7.0.15-7.0.19

Activities

Dambul

2017-04-16 15:47

reporter   ~0004268

I have switched Apache to prefork mode and everything works fine.

But I want to set Apache to mpm-event. Is Xdebug compatible with this mode?

If yes then it seems that the problem is in XDebug compilation.
How can I force phpize to pick correct headers?
There is only one phpize on my server for sure, so there is no way to confuse versions or something like that.

Dambul

2017-04-16 16:41

reporter   ~0004269

Tried "zts-phpize"

and even

./configure --with-php-config=/etc/alternatives/zts-php-config7

Result is the same.

Failed loading /usr/lib64/php-zts/7.0/modules/xdebug.so: /usr/lib64/php-zts/7.0/modules/xdebug.so: undefined symbol: compiler_globals

Dambul

2017-04-16 16:48

reporter   ~0004270

SOLVED

Using "zts-phpize"
AND custom config file for ZTS
./configure --with-php-config=/etc/alternatives/zts-php-config7

Solved the issue, I was just looking to the old logs.

I think it would be nice to somehow mention in documentation this flow for ZTS configuration.
Thank you!

derick

2017-04-17 17:26

administrator   ~0004273

The use of "zts-phpize" is very much not standard to either PHP or Xdebug itself. It seems to be a feature of some distributions, which I can't all support.

We do have some information about phpize with using --with-php-config though at https://xdebug.org/docs/faq#custom-phpize

If you would like to draft an extra FAQ section, or expand on the existing one, feel free to send that to me, or even better would be a pull request for it through github: https://github.com/xdebug/xdebug.org/blob/master/html/docs/include/features.php#L1327

As there is nothing really to fix on my side for this, I am resolving this issue.

Issue History

Date Modified Username Field Change
2017-04-16 13:45 Dambul New Issue
2017-04-16 15:47 Dambul Note Added: 0004268
2017-04-16 16:41 Dambul Note Added: 0004269
2017-04-16 16:48 Dambul Note Added: 0004270
2017-04-17 17:26 derick Note Added: 0004273
2017-04-17 17:26 derick Status new => resolved
2017-04-17 17:26 derick Resolution open => no change required
2017-04-17 17:26 derick Assigned To => derick