View Issue Details

IDProjectCategoryView StatusLast Update
0001442XdebugCode Coveragepublic2017-07-22 11:13
ReportervpassaperaAssigned Toderick 
PriorityhighSeveritymajorReproducibilityalways
Status assignedResolutionopen 
PlatformPHP 7.0.19OSCentosOS Version7
Product Version2.5.3 
Target VersionFixed in Version 
Summary0001442: Incorrect coverage reported seemingly at random points in codebase.
Descriptionhttps://github.com/sebastianbergmann/php-code-coverage/issues/526

I get incorrect coverage reports in a lot of my tests. I have different thresholds in my automation, that I had to lower due to this bug :(

I would like to have my 100% coverage back, please!
TagsNo tags attached.
Operating SystemCentos 7
PHP Version7.0.15-7.0.19

Activities

vpassapera

2017-05-23 19:29

reporter   ~0004346

This still happens in xdebug 2.5.4

derick

2017-07-22 08:29

administrator   ~0004381

And in 2.5.5? It has some more code coverage related fixes: https://xdebug.org/updates.php#x_2_5_5

vpassapera

2017-07-22 11:10

reporter   ~0004383

Last edited: 2017-07-22 11:11

View 3 revisions

It was fixed a few weeks ago (29 days ago to be exact).

All my coverage started reporting 100% again.

I updated the ticket on phpunit coverage.

https://github.com/sebastianbergmann/php-code-coverage/issues/526

vpassapera

2017-07-22 11:13

reporter   ~0004384

Thanks!

Issue History

Date Modified Username Field Change
2017-05-23 19:27 vpassapera New Issue
2017-05-23 19:29 vpassapera Note Added: 0004346
2017-07-22 08:29 derick Note Added: 0004381
2017-07-22 08:29 derick Assigned To => derick
2017-07-22 08:29 derick Status new => feedback
2017-07-22 11:10 vpassapera Note Added: 0004383
2017-07-22 11:10 vpassapera Status feedback => assigned
2017-07-22 11:10 vpassapera Note Edited: 0004383 View Revisions
2017-07-22 11:11 vpassapera Note Edited: 0004383 View Revisions
2017-07-22 11:13 vpassapera Note Added: 0004384