View Issue Details

IDProjectCategoryView StatusLast Update
0001451XdebugInstallationpublic2017-09-02 11:59
ReporterjungalwalaAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSCENTOSOS Version6.9
Product Version2.5.4 
Target VersionFixed in Version 
Summary0001451: Getting the following message in STDERR
Descriptionphp -i
Xdebug requires Zend Engine API version 220131226.
The Zend Engine API version 320151012 which is installed, is newer.
Contact Derick Rethans at http://xdebug.org/docs/faq#api for a later version of Xdebug.
Steps To ReproduceI followed your instructions guide using the wizard (https://xdebug.org/wizard.php)
TagsNo tags attached.
Operating System
PHP Version7.0.20-7.0.24

Activities

derick

2017-07-04 17:11

administrator   ~0004363

Have you looked at what https://xdebug.org/wizard.php says?

jungalwala

2017-07-05 15:14

reporter   ~0004366

Hi Derick,
I am not sure what specifically you are referring to in the wizard. I followed all the instructions listed in the wizard. Here is what I see:

Tailored Installation Instructions

Summary

Xdebug installed: no
Server API: CGI/FastCGI
Windows: no
Zend Server: no
PHP Version: 7.0.20
Zend API nr: 320151012
PHP API nr: 20151012
Debug Build: no
Thread Safe Build: no
Configuration File Path: /opt/cpanel/ea-php70/root/etc
Configuration File: /opt/cpanel/ea-php70/root/etc/php.ini
Extensions directory: /opt/cpanel/ea-php70/root/usr/lib64/php/modules
Instructions

Download xdebug-2.5.4.tgz
Unpack the downloaded file with tar -xvzf xdebug-2.5.4.tgz
Run: cd xdebug-2.5.4
Run: phpize (See the FAQ if you don't have phpize.

As part of its output it should show:

Configuring for:
...
Zend Module Api No: 20151012
Zend Extension Api No: 320151012
If it does not, you are using the wrong phpize. Please follow this FAQ entry and skip the next step.

Run: ./configure
Run: make
Run: cp modules/xdebug.so /opt/cpanel/ea-php70/root/usr/lib64/php/modules
Edit /opt/cpanel/ea-php70/root/etc/php.ini and add the line
zend_extension = /opt/cpanel/ea-php70/root/usr/lib64/php/modules/xdebug.so
Restart the webserver
If you like Xdebug, and thinks it saves you time and money, please have a look at the donation page.

derick

2017-07-22 08:21

administrator   ~0004377

Sorry, I meant to ask whether you have looked at what http://xdebug.org/docs/faq#api said :-)

derick

2017-09-02 11:59

administrator   ~0004403

This is not a bug, please reach out through the support methods at https://xdebug.org/support.php

Issue History

Date Modified Username Field Change
2017-07-04 17:07 jungalwala New Issue
2017-07-04 17:11 derick Note Added: 0004363
2017-07-04 17:11 derick Assigned To => derick
2017-07-04 17:11 derick Status new => feedback
2017-07-05 15:14 jungalwala Note Added: 0004366
2017-07-05 15:14 jungalwala Status feedback => assigned
2017-07-22 08:21 derick Note Added: 0004377
2017-07-22 08:21 derick Status assigned => feedback
2017-09-02 11:59 derick Note Added: 0004403
2017-09-02 11:59 derick Status feedback => resolved
2017-09-02 11:59 derick Resolution open => fixed