View Issue Details

IDProjectCategoryView StatusLast Update
0000147Xdebug(No Category)public2005-09-22 19:25
ReportergarfieldfrAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0000147: Crash PHP.exe under Windows
DescriptionPHP crash when using Xdebug.
I have this warning:
Warning: Call-time pass-by-reference has been deprecated - argument passed by value; If you would like to pass it by reference, modify the declaration of [runtime function name](). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. However, future versions may not support this any longer. in d:\xxxxx\class.frontController.php on line 95

I know why this warning but when i disable Xdebug the code work well.

Additional InformationOS: Windows 2000 SP4
Serveur Apache 1.3.31 as service
PHP 4.3.5, 4.3.8 CGI mode
Tested with
xdebug-4.3.6-2.0.0beta1.dll,
xdebug-4.3-1.3.2.dll
and xdebug-4.3-2.0dev.dll
TagsNo tags attached.
Operating SystemWindows 2000 Pro SP4
PHP Version4.3.10

Activities

garfieldfr

2005-09-16 19:28

reporter   ~0000282

Forgot this bug, it was a probleme in my configuration. I was set
xdebug.remote_handler=bdgp
instead of
xdebug.remote_handler=dbgp

very hard to find !

derick

2005-09-22 19:25

administrator   ~0000287

Not a bug, marking as such.

Issue History

Date Modified Username Field Change
2005-09-12 15:26 garfieldfr New Issue
2005-09-16 19:28 garfieldfr Note Added: 0000282
2005-09-22 19:25 derick Status new => resolved
2005-09-22 19:25 derick Resolution open => no change required
2005-09-22 19:25 derick Assigned To => derick
2005-09-22 19:25 derick Note Added: 0000287
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)