View Issue Details

IDProjectCategoryView StatusLast Update
0001480XdebugCode Coveragepublic2018-01-29 21:48
ReporterVIVEK.SIT@GMAIL.COMAssigned Toderick 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version2.5.5 
Target VersionFixed in Version 
Summary0001480: Number of lines in the file are different incase file is covered and uncovered.
DescriptionI have 2200 test cases in my repo which takes around 8 hours to run using xdebug for code coverage.

 I was trying to write a script which will run all test class independently and collate the result into a single result.
I stumbled on this bug which blocked me.
Steps To ReproduceClassFile - BadRequestException.php
TC 1.
    Run a test case which does not cover the code
Result:
    The number of uncovered line is show as 8.
    The number of uncovered line is show as 0.

TC 1.
    Run a test case which covers the code of the same file
Result:
    The number of uncovered line is show as 0.
    The number of uncovered line is show as 3.
Additional InformationAttached snapshot.
TagsNo tags attached.
Operating System
PHP Version7.1.0-7.1.4

Activities

VIVEK.SIT@GMAIL.COM

2017-10-16 08:42

reporter  

xdebug_error.jpg (592,625 bytes)

derick

2017-11-01 21:42

administrator   ~0004449

Please provide a short reproducible case (test case + script + instructions how to run this), so that I can try to reproduce this myself please.

derick

2018-01-29 21:48

administrator   ~0004581

Can't reproduce this, and no feedback provided.

Issue History

Date Modified Username Field Change
2017-10-16 08:42 VIVEK.SIT@GMAIL.COM New Issue
2017-10-16 08:42 VIVEK.SIT@GMAIL.COM File Added: xdebug_error.jpg
2017-11-01 21:42 derick Note Added: 0004449
2017-11-01 21:42 derick Assigned To => derick
2017-11-01 21:42 derick Status new => feedback
2018-01-29 21:48 derick Note Added: 0004581
2018-01-29 21:48 derick Status feedback => resolved
2018-01-29 21:48 derick Resolution open => unable to reproduce