View Issue Details

IDProjectCategoryView StatusLast Update
0001491XdebugUsage problems (Wrong Results)public2017-11-18 11:18
ReporterltikkuAssigned Toderick 
PriorityhighSeveritymajorReproducibilityalways
Status acknowledgedResolutionopen 
PlatformOSWindowsOS Versionwindows 10
Product Version2.5.5 
Target VersionFixed in Version 
Summary0001491: unexpected reference count
DescriptionI have xampp version 3.2.2 insalled, PHP version 7.1.1,
xdebug extension https://xdebug.org/files/php_xdebug-2.5.5-7.1-vc14.dll

I have the PHP code
$a = "new string";
xdebug_debug_zval( 'a' );

That outputs
a:
(refcount=2, is_ref=0)string 'new string' (length=10)


that refcount should be refcount=1

this is unexpected behaviour

my setting in php.ini is
[XDebug]
zend_extension="D:\xampp\php\ext\php_xdebug.dll"
xdebug.remote_enable=1
xdebug.remote_handler="dbgp"
xdebug.remote_host="127.0.0.1"
xdebug.remote_port=9000
TagsNo tags attached.
Operating System
PHP Version7.1.0-7.1.4

Activities

derick

2017-11-18 11:18

administrator   ~0004468

There is indeed something weird going on here, and it got likely introduced with https://github.com/xdebug/xdebug/commit/2ddad8ecf219bd7e92bcb6807ead39a84d5c5718

It is unlikely that I will be able to fix this before Xdebug 2.6 is released.

Issue History

Date Modified Username Field Change
2017-11-15 17:20 ltikku New Issue
2017-11-18 11:18 derick Note Added: 0004468
2017-11-18 11:18 derick Assigned To => derick
2017-11-18 11:18 derick Status new => acknowledged