View Issue Details

IDProjectCategoryView StatusLast Update
0001499XdebugRemote Debuggingpublic2017-12-05 14:24
ReportermlocatiAssigned Toderick 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformWindowsOSWindowsOS Version10
Product Version 
Target VersionFixed in Version 
Summary0001499: property_set: unable to change array item value
DescriptionI'm trying to change an array item value using the DBGP protocol.

Let's assume I want to set the 'foo bar' key of the $a array to the 'lorem2' string (bG9yZW0y in base64).

I tried all these commands:

property_set -t string -n $a["foo bar"] -d 0 -l 8 -- bG9yZW0y
property_set -t string -n $a['foo bar'] -d 0 -l 8 -- bG9yZW0y
property_set -t string -n $a[\"foo bar\"] -d 0 -l 8 -- bG9yZW0y
property_set -t string -n $a["foo bar"] -d 0 -l 8 -- bG9yZW0y

but xdebug always responds with an error (code: 1, message: parse error in command).

Am I missing something?
Additional InformationTested this in xdebug 2.6.0alpha1 with the DLL from https://pecl.php.net/package/xdebug
TagsNo tags attached.
Operating SystemWindows 10
PHP Version7.2.0-7.2.4

Relationships

duplicate of 0001488 closedderick Rewrite property_set to use eval 

Activities

mlocati

2017-12-05 13:44

reporter   ~0004500

I also tried with

property_set -t string -n "$a[\"foo bar\"]" -d 0 -l 8 -- bG9yZW0y

In this case, I get a successful response from xdebug (success="1"), but the actual value of the array doesn't change.

derick

2017-12-05 14:00

administrator   ~0004501

In all of your example, you miss the "-i <id>", unless you didn't show the full commands?

In any case, this is a duplicate of: https://bugs.xdebug.org/view.php?id=1488

I also asked people on twitter about this: https://twitter.com/xdebug/status/919557985264979968

mlocati

2017-12-05 14:24

reporter   ~0004502

> In all of your example, you miss the "-i <id>", unless you didn't show the full commands?

Yes, sorry, I only wrote the partial commands. All the above commands have the "-i <id>" parameter.

Looking forward for the resolution of 0001488

Thanks!

Issue History

Date Modified Username Field Change
2017-12-05 13:19 mlocati New Issue
2017-12-05 13:44 mlocati Note Added: 0004500
2017-12-05 14:00 derick Note Added: 0004501
2017-12-05 14:00 derick Relationship added duplicate of 0001488
2017-12-05 14:00 derick Status new => resolved
2017-12-05 14:00 derick Resolution open => duplicate
2017-12-05 14:00 derick Assigned To => derick
2017-12-05 14:24 mlocati Note Added: 0004502