View Issue Details

IDProjectCategoryView StatusLast Update
0001539XdebugRemote Debuggingpublic2018-03-31 00:19
ReporterjabranrAssigned Toderick 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionnot fixable 
PlatformAnyOSOS Version
Product Version2.6.0 
Target VersionFixed in Version 
Summary0001539: Add support from .xdebug file for path mapping
DescriptionAdd support for .xdebug file in project root so that path mapping can be defined there instead of the IDE specifically. This will allow project maintainers to setup path mapping in certain scenarios where they would like the support for xdebug out of the box of their setup. Since this is already in a JSON format so it should be trivial to follow.
TagsNo tags attached.
Operating System
PHP Version7.1.0-7.1.4

Activities

derick

2018-03-30 17:21

administrator   ~0004626

Path mappings are a feature of IDEs, and not of Xdebug. Xdebug only reports the real file names on the file systems where it is run, and it is up to the IDE to match these remote paths with local ones. Because this is an IDE feature, nothing can be done on the Xdebug side.

jabranr

2018-03-31 00:19

reporter   ~0004627

Understood. Thank you for the explanation, Derick.

Issue History

Date Modified Username Field Change
2018-03-21 17:01 jabranr New Issue
2018-03-30 17:21 derick Note Added: 0004626
2018-03-30 17:21 derick Status new => resolved
2018-03-30 17:21 derick Resolution open => not fixable
2018-03-30 17:21 derick Assigned To => derick
2018-03-31 00:19 jabranr Note Added: 0004627