View Issue Details

IDProjectCategoryView StatusLast Update
0000155XdebugUsage problems (Wrong Results)public2006-01-17 21:29
ReportermccabeAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000155: Cannot watch array elements
Descriptionin php, i have an array like:

     $a = array();
     $a['test'] = 'test';
     $a[1] = 'xxx';

I can watch $a, but if I request the value of $a[1] I get the full array in response, same if I request $a["test"].

If I reqest $a['test'] I get a crash.

Additional InformationTo request $a[1], I send:
property_get -i 93 -n $a[1]

As reply, I get:
<response command="property_get" transaction_id="93"><property name="$a[1]" fullname="$a[1]" address="135490860" type="array" children="1" numchildren="2"><property name="1" fullname="$a[1][1]" address="135477484" type="string" encoding="base64"><![CDATA[dGVzdA==]]></property><property name="test" fullname="$a[1]['test']" address="135480372" type="string" encoding="base64"><![CDATA[dGVzdA==]]></property></property></response>

To requeat $a['test'] I do:
property_get -i 94 -n $a["test"]

The response is:
<response command="property_get" transaction_id="94"><property name="$a["test"]" fullname="$a["test"]" address="135490860" type="array" children="1" numchildren="2"><property name="1" fullname="$a["test"][1]" address="135477484" type="string" encoding="base64"><![CDATA[dGVzdA==]]></property><property name="test" fullname="$a["test"]['test']" address="135480372" type="string" encoding="base64"><![CDATA[dGVzdA==]]></property></property></response>

To request $a['test'] I send:
property_get -i 130 -n $a['test']

I get no response, but in apache error log I get:
*** glibc detected *** free(): invalid pointer: 0x08133bf4 ***
[Sun Oct 16 00:52:23 2005] [notice] child pid 12635 exit signal Aborted (6)
TagsNo tags attached.
Operating SystemLinux linus 2.6.11-1-686
PHP Version4.3.11

Activities

derick

2005-12-30 14:42

administrator   ~0000318

Can you try this with 2.0.0beta4 (from pecl.php.net/xdebug)?

derick

2006-01-17 21:29

administrator   ~0000339

I can not reproduce this, nor did I receive any feedback for my last comment.

Issue History

Date Modified Username Field Change
2005-10-15 23:54 mccabe New Issue
2005-12-30 14:42 derick PHP Version 4.3.10 => 4.3.11
2005-12-30 14:42 derick Xdebug Version 2.0-dev => 2.0.0beta2
2005-12-30 14:42 derick Note Added: 0000318
2005-12-30 14:42 derick Status new => feedback
2006-01-17 21:29 derick Status feedback => resolved
2006-01-17 21:29 derick Resolution open => unable to reproduce
2006-01-17 21:29 derick Assigned To => derick
2006-01-17 21:29 derick Note Added: 0000339
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)