View Issue Details

IDProjectCategoryView StatusLast Update
0000157XdebugUsage problems (Wrong Results)public2006-01-17 21:24
ReporterselkirkAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityrandom
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000157: Consistent Random Memory Corruption
DescriptionI'm experiencing fairly consistent memory corruption problems while collecting code coverage information for a large test suite (covering hundreds of files). These show up as odd PHP errors and failing test cases that occur only with XDebug loaded. I have not yet been able to complete a run of the whole test suite without encountering one of these errors. The test suite runs fine when XDebug is not loaded.
Additional InformationI've tried with both php 5.0.1 and php 5.0.4. I have not been able to try with 5.0.5 because my application and SimpleTest do not yet work with PHP versions >= 5.0.5.
TagsNo tags attached.
Operating SystemMac OS X 10.3.9
PHP Version5.0.4

Activities

derick

2005-10-19 09:18

administrator   ~0000298

Can you please try the latest beta (2.0.0beta4) if you didn't do that yet, and update the bugreport with the new Xdebug version filled in correctly? If you already did that I really need a short reproducable script, or a valgrind trace in order to figure out what is going wrong. We found no problems here utilizing codecoverage with a huge PHPUnit2 run f.e. (but that's with PHP 5.1.0rc3)

selkirk

2005-10-19 15:40

reporter   ~0000300

The latest version listed on the web site is 2.0.0beta2, so I assume that beta4 is the cvs version? I will re-try with the cvs version. Yesterday, I noticed a spurious test failure during a regular test run with xdebug loaded but coverage not enabled. Running a second time produced correct results. So, I don't think the problem is not limited to just during coverage reports.

selkirk

2005-10-21 00:37

reporter   ~0000302

I checked out the latest version from CVS. How do I create ./configure?

It might be helpful to mention that under the "Compiling from Source" section on http://xdebug.org/install.php

Thanks

selkirk

2005-10-21 00:40

reporter   ~0000303

Ok, my bad. Forgot the phpize step. I never knew what that did. Now I do. :)

derick

2005-12-30 14:40

administrator   ~0000317

Is the issue solved now?

derick

2006-01-17 21:24

administrator   ~0000334

Closing as I can't duplicate this nor is there any more feedback.

Issue History

Date Modified Username Field Change
2005-10-18 15:40 selkirk New Issue
2005-10-19 09:18 derick Note Added: 0000298
2005-10-19 15:40 selkirk Note Added: 0000300
2005-10-21 00:37 selkirk Note Added: 0000302
2005-10-21 00:40 selkirk Note Added: 0000303
2005-12-30 14:40 derick Xdebug Version 2.0.0beta2 => 2.0.0beta5-dev
2005-12-30 14:40 derick Note Added: 0000317
2005-12-30 14:40 derick Status new => feedback
2006-01-17 21:24 derick Status feedback => resolved
2006-01-17 21:24 derick Resolution open => unable to reproduce
2006-01-17 21:24 derick Assigned To => derick
2006-01-17 21:24 derick Note Added: 0000334
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)