View Issue Details

IDProjectCategoryView StatusLast Update
0001585XdebugRemote Debuggingpublic2018-11-21 10:00
ReporternikeosAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSWindowsOS VersionWindows 8.1
Product Version2.7.0beta1 
Target VersionFixed in Version 
Summary0001585: Hung out on step over for PHP7.3 + Nginx + Windows 8.1
DescriptionTrying to debug php script run as phpfcgi with nginx on windows.
Catching request from browser and stoping on first line is ok. But debug hunging out after firts step. Connection still opened but nothing happens. Any errors in php or nginx error logs.
Steps To ReproduceInstall configure and run php-fcgi with nginx (https://www.nginx.com/resources/wiki/start/topics/examples/phpfastcgionwindows/)
Run php-fcgi
Run nginx
Start listening port
Run script debugging
Stop on first line
Press F8 (Step Over)
Additional InformationTools:
Nginx 1.15.5
PHP 7.3 (7.3.0RC4) VC15 x64 Thread Safe
Xdebug 2.7.0beta1 - PHP 7.3 VC15 TS (64 bit)
PHPStorm 2018.1.6 (Build #PS-181.5281.35, built on June 14, 2018)
Windows 8.1

nginx.conf

worker_processes 1;
error_log logs/error.log notice;
pid logs/nginx.pid;
events {
    worker_connections 1024;
}

http {
    include mime.types;
    default_type application/octet-stream;
    sendfile on;
    keepalive_timeout 65;
    proxy_buffer_size 128k;
    proxy_buffers 4 256k;
    proxy_busy_buffers_size 256k;
    fastcgi_buffer_size 128k;
    fastcgi_buffers 4 256k;
    fastcgi_busy_buffers_size 256k;
    fastcgi_read_timeout 300;
    
    server {
        listen 80;
        server_name localhost xxx.local www.xxx.local;
        access_log logs/access.xxx.local.log combined;
        error_log logs/error.xxx.local.log notice;
        root "d:/xxx/src/web";
        index index.php index.html;
        location / {
            root "d:/xxx/src/web";
            index index.php index.html;
            try_files $uri $uri/ /index.php;
        }
        location ~ \.php$ {
            root "d:/xxx/src/web";
            include C:/programs/nginx-1.15.5/conf/fastcgi.conf;
            fastcgi_pass 127.0.0.1:9123;
            fastcgi_index index.php;
            fastcgi_param SCRIPT_FILENAME
 $document_root$fastcgi_script_name;
        }
    }
}

XDebug config in attached php.ini file
TagsNo tags attached.
Operating SystemWindows 8.1
PHP Version7.3-dev

Activities

nikeos

2018-10-31 12:36

reporter  

php.ini (74,277 bytes)

nikeos

2018-11-02 12:18

reporter   ~0004719

Replaced Nginx by Apache 2.4.37 and checked xDebug behavior. Nothing changes. Still Time-out connecting to client.

nikeos

2018-11-02 13:09

reporter   ~0004720

Finally:

1. php-7.1.23-Win32-VC14-x64 + php_xdebug-2.6.1-7.1-vc14-x86_64.dll
2. php-7.2.11-Win32-VC15-x64 + php_xdebug-2.6.1-7.2-vc15-x86_64.dll
Both works fine with apache and nginx.

1. php-7.1.23-Win32-VC14-x64 + php_xdebug-2.7.0beta1-7.1-vc14-x86_64.dll
2. php-7.2.11-Win32-VC15-x64 + php_xdebug-2.7.0beta1-7.2-vc15-x86_64.dll
3. php-7.3.0RC4-Win32-VC15-x64 + php_xdebug-2.7.0beta1-7.3-vc15-x86_64.dll
Throw: Time-out connecting to client.

P.S. Maybe it's a problem of PHPStorm not xDebug but i have no idea how to check it.

nikeos

2018-11-02 20:54

reporter   ~0004721

UPD.

Problem localized.
In PhpStorm library (c:\Program Files\JetBrains\PhpStorm 2018.2.5\plugins\php\lib\php.jar) hardcoded "http://xdebug.org/dbgp/xdebug" but not "https://xdebug.org/dbgp/xdebug"

Seems it not work after xdebug commit on Sep 20, 2018 "Change http://xdebug.org to https://xdebug.org everywhere"

nikeos

2018-11-05 10:08

reporter   ~0004722

UPD

https://xdebug.org/dbgp/xdebug - return 404

derick

2018-11-21 10:00

administrator   ~0004726

I ran into this myself, and found out it was a bug in PhpStorm: https://youtrack.jetbrains.com/issue/WI-43622 — their latest EAP version has it fixed, and can be downloaded from https://www.jetbrains.com/phpstorm/nextversion/

As this is not a bug in Xdebug, I will be closing this report. I will make sure that URL exists though (and redirects to https://xdebug.org/docs-dbgp.php). Thanks for filing it!

Issue History

Date Modified Username Field Change
2018-10-31 12:36 nikeos New Issue
2018-10-31 12:36 nikeos File Added: php.ini
2018-11-02 12:18 nikeos Note Added: 0004719
2018-11-02 13:09 nikeos Note Added: 0004720
2018-11-02 20:54 nikeos Note Added: 0004721
2018-11-05 10:08 nikeos Note Added: 0004722
2018-11-21 10:00 derick Note Added: 0004726
2018-11-21 10:00 derick Status new => resolved
2018-11-21 10:00 derick Resolution open => fixed
2018-11-21 10:00 derick Assigned To => derick