View Issue Details

IDProjectCategoryView StatusLast Update
0001605XdebugUsage problems (Wrong Results)public2019-01-22 22:04
Reportergte451fAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionduplicate 
PlatformLinuxOSUbuntuOS Version18.04
Product Version2.7.0beta1 
Target VersionFixed in Version 
Summary0001605: XDebugs causes crash while using Composer
DescriptionOn a fresh install, the following Composer command crashes, but only while Xdebug is enabled. Once xdebug is disabled, the command works w/o any problems.

composer create-project symfony/skeleton [PROJECT-NAME]

Steps To ReproduceStart w/ a fresh copy of Ubuntu 18.04
Use this PPA to install latest PHP on Ubuntu: ondrej/php
Install Composer (1.8.0)
Run this command:
composer create-project symfony/skeleton [PROJECT-NAME]
Additional InformationError returned by composer is:

Installing symfony/skeleton (v4.2.2.1)
  - Installing symfony/skeleton (v4.2.2.1): Loading from cache
Created project in bookshop-api
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Package operations: 22 installs, 0 updates, 0 removals
  - Installing symfony/flex (v1.1.8): Loading from cache
  - Installing psr/cache (1.0.1): Loading from cache
  - Installing psr/container (1.0.0): Loading from cache
  - Installing psr/simple-cache (1.0.1): Loading from cache
  - Installing symfony/polyfill-mbstring (v1.10.0): Loading from cache
  - Installing symfony/contracts (v1.0.2): Loading from cache
  - Installing symfony/console (v4.2.2): Loading from cache
  - Installing symfony/dotenv (v4.2.2): Loading from cache
  - Installing symfony/routing (v4.2.2): Loading from cache
  - Installing symfony/http-foundation (v4.2.2): Loading from cache
  - Installing symfony/event-dispatcher (v4.2.2): Loading from cache
  - Installing psr/log (1.1.0): Loading from cache
  - Installing symfony/debug (v4.2.2): Loading from cache
  - Installing symfony/http-kernel (v4.2.2): Loading from cache
  - Installing symfony/finder (v4.2.2): Loading from cache
  - Installing symfony/filesystem (v4.2.2): Loading from cache
  - Installing symfony/dependency-injection (v4.2.2): Loading from cache
  - Installing symfony/config (v4.2.2): Loading from cache
  - Installing symfony/var-exporter (v4.2.2): Loading from cache
  - Installing symfony/cache (v4.2.2): Loading from cache
  - Installing symfony/framework-bundle (v4.2.2): Loading from cache
  - Installing symfony/yaml (v4.2.2): Loading from cache
Generating autoload files
Symfony operations: 4 recipes (88b471b4d42fa4cfad30670f1394e2d4)
  - Configuring symfony/flex (>=1.0): From github.com/symfony/recipes:master
  - Configuring symfony/framework-bundle (>=4.2): From github.com/symfony/recipes:master
  - Configuring symfony/console (>=3.3): From github.com/symfony/recipes:master
  - Configuring symfony/routing (>=4.2): From github.com/symfony/recipes:master
Executing script cache:clear [KO]
 [KO]
Script cache:clear returned with error code 139
!! Segmentation fault (core dumped)
!!
Script @auto-scripts was called via post-install-cmd
TagsNo tags attached.
Operating SystemUbuntu 18.04
PHP Version7.3.0

Relationships

duplicate of 0001583 closedderick Xdebug crashes when OPcache's compact literals optimisation is on 

Activities

derick

2019-01-17 12:12

administrator   ~0004817

1. Do you have OPcache turned on?
2. Can you install GDB, and run the following:

gdb php `which composer` create-project symfony/skeleton [PROJECT-NAME]

On the GDB prompt, type: "run"

When it crashes, please instruct GDB to create a backtrace with "bt full", and then add that backtrace as a *file* to this report please.

derick

2019-01-22 22:04

administrator   ~0004825

No feedback provided, but I will assume this is the same issue as 0001583.

Issue History

Date Modified Username Field Change
2019-01-12 17:59 gte451f New Issue
2019-01-17 12:12 derick Note Added: 0004817
2019-01-17 12:12 derick Assigned To => derick
2019-01-17 12:12 derick Status new => feedback
2019-01-22 22:04 derick Note Added: 0004825
2019-01-22 22:04 derick Relationship added duplicate of 0001583
2019-01-22 22:04 derick Status feedback => resolved
2019-01-22 22:04 derick Resolution open => duplicate