View Issue Details

IDProjectCategoryView StatusLast Update
0001607XdebugUsage problems (Wrong Results)public2019-01-17 11:51
ReporternoodlesAssigned Toderick 
PrioritynormalSeveritymajorReproducibilitysometimes
Status resolvedResolutionduplicate 
PlatformPHP 7.3.1OSCentosOS Version7.6
Product Version2.7.0beta1 
Target VersionFixed in Version 
Summary0001607: Warning Illegal offset type when using XDebug and Opcache with PHP 7.3
DescriptionWhen Twig is loaded on a page, while it works the first time, additional refreshes fail with:

Warning: Illegal offset type in /home/test/vendor/twig/twig/lib/Twig/Loader/Filesystem.php on line 80

Warning: Illegal offset type in /home/test/vendor/twig/twig/lib/Twig/Loader/Filesystem.php on line 104

I'm assuming that it works on the first pageview because the opcache is not primed.

Originally I thought this was an issue with Twig (see https://github.com/twigphp/Twig/issues/2781), but it turns out when running PHP 7.3.1 with opcache and Xdebug 2.7.0beta1 (have also tried using aeb3c3a99f1ece0e2c98e8917631c773ec96dfd8 commit for xdebug from git, which was the latest commit today).

If Xdebug is disabled, then it works fine. If Opcache is disabled then it works fine. With both enabled, it doesn't work.
Steps To Reproducegit clone https://github.com/noodlesnz/php-bug.git
cd php-bug
composer install

View index.php in a browser and hit refresh once or twice.
TagsNo tags attached.
Operating System
PHP Version7.3.0

Relationships

duplicate of 0001583 closedderick Xdebug crashes when OPcache's compact literals optimisation is on 

Activities

derick

2019-01-17 11:51

administrator   ~0004812

This is very likely the same problem as 0001583, which has a workaround: https://bugs.xdebug.org/view.php?id=1583#c4774

Issue History

Date Modified Username Field Change
2019-01-14 22:34 noodles New Issue
2019-01-17 11:51 derick Note Added: 0004812
2019-01-17 11:51 derick Relationship added duplicate of 0001583
2019-01-17 11:51 derick Status new => resolved
2019-01-17 11:51 derick Resolution open => duplicate
2019-01-17 11:51 derick Assigned To => derick