View Issue Details

IDProjectCategoryView StatusLast Update
0000164Xdebug(No Category)public2006-01-24 22:42
ReporterOpikAssigned Toderick 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000164: flock() freeze
DescriptionWhen I use
flock($fp, LOCK_EX);
my PHP script get freezed. When I turned off xdebug extention this was OK.
TagsNo tags attached.
Operating SystemRHEL3
PHP Version5.0.5

Activities

derick

2006-01-17 08:52

administrator   ~0000331

I need a bit more information - like a *short* reproducing script. The flock() function itself works fine. Are you also sure you're using PHP 5.0.5?

Opik

2006-01-17 22:31

reporter   ~0000342

Yes, Im sure, that I use PHP 5.0.5
As extentions I use also: eaccelerator and memcache. mb eaccelerator occurs error?

Opik

2006-01-17 23:33

reporter   ~0000348

code:
$fp = fopen($user_data_file, "r+");
if(!$fp) exit;

flock($fp, LOCK_EX); // then I comment this line, scripts works
fseek($fp,0);

Opik

2006-01-18 00:14

reporter   ~0000349

I think it was permission error

derick

2006-01-18 22:37

administrator   ~0000352

It's very possible that other extension affect this, and that it is not Xdebug's fault at all. In your last comment you say that it might have been a permission error, but for that to make sense to me you need to be a bit more clearer. Do you mean it was an error on your site? or what was the full error message? I also didn't see a full reproducable script (which I can copy and paste and works immediately)

derick

2006-01-24 22:42

administrator   ~0000364

Can't reproduce this, nor did I receive any feedback whether this still is an issue. Please reopen when you can provide the requested information.

Issue History

Date Modified Username Field Change
2006-01-16 16:57 Opik New Issue
2006-01-17 08:52 derick Note Added: 0000331
2006-01-17 08:52 derick Status new => feedback
2006-01-17 22:31 Opik Note Added: 0000342
2006-01-17 23:33 Opik Note Added: 0000348
2006-01-18 00:14 Opik Note Added: 0000349
2006-01-18 22:37 derick Note Added: 0000352
2006-01-24 22:42 derick Status feedback => resolved
2006-01-24 22:42 derick Resolution open => unable to reproduce
2006-01-24 22:42 derick Assigned To => derick
2006-01-24 22:42 derick Note Added: 0000364
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)