View Issue Details

IDProjectCategoryView StatusLast Update
0001657XdebugInstallationpublic2019-04-17 14:08
ReportermarcobraghimAssigned Toderick 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionno change required 
PlatformLinuxOSDeepinOS VersionDeepin 15.9.3
Product Version2.7.1 
Target VersionFixed in Version 
Summary0001657: Error to 'make' installation
Description/bin/bash /home/jessie/Downloads/xdebug-2.7.1/libtool --mode=compile cc -I. -I/home/jessie/Downloads/xdebug-2.7.1 -DPHP_ATOM_INC -I/home/jessie/Downloads/xdebug-2.7.1/include -I/home/jessie/Downloads/xdebug-2.7.1/main -I/home/jessie/Downloads/xdebug-2.7.1 -I/usr/include/php/20170718 -I/usr/include/php/20170718/main -I/usr/include/php/20170718/TSRM -I/usr/include/php/20170718/Zend -I/usr/include/php/20170718/ext -I/usr/include/php/20170718/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /home/jessie/Downloads/xdebug-2.7.1/xdebug.c -o xdebug.lo
libtool: Version mismatch error. This is libtool 2.4.2 Debian-2.4.2-1.11, but the
libtool: definition of this LT_INIT comes from libtool 2.4.6.
libtool: You should recreate aclocal.m4 with macros from libtool 2.4.2 Debian-2.4.2-1.11
libtool: and run autoconf again.
make: *** [Makefile:226: xdebug.lo] Error 63
Steps To ReproduceTailored Installation Instructions
Summary
Xdebug installed: no
Server API: Command Line Interface
Windows: no
Zend Server: no
PHP Version: 7.2.17-1
Zend API nr: 320170718
PHP API nr: 20170718
Debug Build: no
Thread Safe Build: no
OPcache Loaded: no
Configuration File Path: /etc/php/7.2/cli
Configuration File: /etc/php/7.2/cli/php.ini
Extensions directory: /usr/lib/php/20170718
Instructions:

1. Download xdebug-2.7.1.tgz
2. Install the pre-requisites for compiling PHP extensions. These packages are often called 'php-dev', or 'php-devel', 'automake' and 'autoconf'.
3. Unpack the downloaded file with tar -xvzf xdebug-2.7.1.tgz
4. Run: cd xdebug-2.7.1
5. Run: phpize (See the FAQ if you don't have phpize).

As part of its output it should show:

Configuring for:
...
Zend Module Api No: 20170718
Zend Extension Api No: 320170718
If it does not, you are using the wrong phpize. Please follow this FAQ entry and skip the next step.

6. Run: ./configure
7. Run: make <------ My error occurs after this command

8. Run: cp modules/xdebug.so /usr/lib/php/20170718
9. Edit /etc/php/7.2/cli/php.ini and add the line
zend_extension = /usr/lib/php/20170718/xdebug.so
Additional Informationlibtool --version:
libtool (GNU libtool) 2.4.6
Written by Gordon Matzigkeit, 1996

Copyright (C) 2014 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
TagsNo tags attached.
Operating SystemDeepin 15.9.3
PHP Version7.2.10-7.2.14

Activities

marcobraghim

2019-04-17 12:44

reporter   ~0004999

Sorry for that, I solved it running the instructions here: https://stackoverflow.com/questions/3096989/libtool-version-mismatch-error

autoreconf --force --install
./configure
make

This issue can be closed as well. Thank you

derick

2019-04-17 14:08

administrator   ~0005000

Done - thanks.

Issue History

Date Modified Username Field Change
2019-04-17 12:36 marcobraghim New Issue
2019-04-17 12:44 marcobraghim Note Added: 0004999
2019-04-17 14:08 derick Assigned To => derick
2019-04-17 14:08 derick Status new => resolved
2019-04-17 14:08 derick Resolution open => no change required
2019-04-17 14:08 derick Note Added: 0005000