View Issue Details

IDProjectCategoryView StatusLast Update
0001678XdebugInstallationpublic2019-07-12 07:59
ReporterjayapalchandranAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
PlatformWindowsOSWindows 10OS Version1709
Product Version2.5.4 
Target VersionFixed in Version 
Summary0001678: Failed loading php_xdebug-2.5.4-5.6-vc11-nts-x86_64.dll
DescriptionI am using xampp, PHP version is 5.6.2
In that xdebug is getting loaded. I can see that from phpinfo and from the command line(php -v)

C:\>c:\xampp\php-5.6.2\php -v
PHP 5.6.20 (cli) (built: Mar 31 2016 14:56:44)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    with Xdebug v2.2.5, Copyright (c) 2002-2014, by Derick Rethans

But when running the php application i get max 30 seconds timeout error.
I removed all set_time_out function calls.
Still i get that error on line where there is an in_array function.
the xdebug version provided with the xampp/php(5.6.2) is 2.2.5

I came across a discussion and in that I can see that the time out error has been fixed in xdebug version 2.5.4.
https://bugs.xdebug.org/view.php?id=1424

So, I downloaded php_xdebug-2.5.4-5.6-vc11-nts-x86_64.dll and moved it to the ext folder.
I, then changed the file path in php.ini accordingly.

[XDebug]
;zend_extension = "C:\xampp\php-5.6.2\ext\php_xdebug.dll"
zend_extension = "C:\xampp\php-5.6.2\ext\php_xdebug-2.5.4-5.6-vc11-nts-x86_64.dll"
;zend_extension = "C:\xampp\php\ext\php_xdebug.dll"
;xdebug.profiler_append = 0
;xdebug.profiler_enable = 1
;xdebug.profiler_enable_trigger = 0
;xdebug.profiler_output_dir = "C:\xampp\tmp"
;xdebug.profiler_output_name = "cachegrind.out.%t-%s"
xdebug.remote_enable = 1
xdebug.remote_handler = "dbgp"
xdebug.remote_host = "127.0.0.1"
xdebug.trace_output_dir = "C:\xampp\tmp"

After this from the command line i executed php -v and then i get something like this.
I have also ran phpinfo and in could not find xdebug entry.

C:\>c:\xampp\php-5.6.2\php -v
Failed loading C:\xampp\php-5.6.2\ext\php_xdebug-2.5.4-5.6-vc11-nts-x86_64.dll
PHP 5.6.20 (cli) (built: Mar 31 2016 14:56:44)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies

I have also tried xdebug version 2.5.5. It is the same as the above.

What should i do to make xdebug work with php 5.6.2?

Steps To ReproduceAs mentioned in the description
Tagsfailed loading
Operating SystemWindows 10
PHP Version5.6.20-5.6.24

Activities

derick

2019-07-12 07:59

administrator   ~0005056

Sorry, but I no longer support PHP 5. Please upgrade your XAMPP to get a still support version of PHP.

Issue History

Date Modified Username Field Change
2019-06-29 09:41 jayapalchandran New Issue
2019-06-29 09:41 jayapalchandran Tag Attached: failed loading
2019-07-12 07:59 derick Assigned To => derick
2019-07-12 07:59 derick Status new => resolved
2019-07-12 07:59 derick Resolution open => no change required
2019-07-12 07:59 derick Note Added: 0005056