View Issue Details

IDProjectCategoryView StatusLast Update
0001681XdebugStep Debuggingpublic2020-03-12 16:43
ReporterkrakjoeAssigned Toderick 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0001681: Reduce cost of getpid() syscall to once per request/thread/process
Descriptiongetpid() is expensive, and should only be called once per request

Original PR: https://github.com/xdebug/xdebug/pull/487, by Joe Watkins
TagsNo tags attached.
Operating System
PHP Version7.3.5-7.3.9

Relationships

duplicate of 0001755 closedderick Overload pcntl_fork() to prevent performance degradation by calling xdebug_get_pid often 
related to 0001687 closedderick Use appropriate process ID for logging and "is this the right process" tracking 

Activities

derick

2020-03-12 16:27

administrator   ~0005292

Duplicate of 0001755, which has a much more elegant solution that doesn't rely on pthreads.

Issue History

Date Modified Username Field Change
2019-07-10 12:48 krakjoe New Issue
2019-07-19 12:15 derick Status new => acknowledged
2019-07-19 12:15 derick Summary Reduce cost of getpid syscall to once per request => Reduce cost of getpid() syscall to once per request/thread/process
2019-07-19 12:15 derick Description Updated View Revisions
2019-07-19 12:16 derick Relationship added related to 0001687
2020-03-12 16:23 derick Severity minor => feature
2020-03-12 16:27 derick Assigned To => derick
2020-03-12 16:27 derick Status acknowledged => resolved
2020-03-12 16:27 derick Resolution open => duplicate
2020-03-12 16:27 derick Note Added: 0005292
2020-03-12 16:27 derick Relationship added duplicate of 0001755
2020-03-12 16:43 derick Category Feature/Change request => Step Debugging