View Issue Details

IDProjectCategoryView StatusLast Update
0001692XdebugRemote Debuggingpublic2019-09-06 16:37
ReporterdinuAssigned Toderick 
PriorityhighSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version2.8.0beta1 
Target VersionFixed in Version 
Summary0001692: Segfault with object-type object property
DescriptionI get a hard crash (usually segfault) when I add to watches an object property (i.e. $x->a) that is also an object instance. Other type object properties seem to work, adding the whole object and then expanding the object-type property also works.

PHP version is 7.2.20 but it doesn't appear in the PHP version dropdown.
TagsNo tags attached.
Operating System
PHP Version7.2.15-7.2.19

Activities

dinu

2019-08-06 18:38

reporter   ~0005110

xdebug 2.7.2 does not exhibit same bug

derick

2019-08-09 16:12

administrator   ~0005111

Please provide all the information that is requested at https://xdebug.org/support.php#remote for step debugger bugs.

derick

2019-09-06 11:26

administrator   ~0005135

I can't reproduce this, and the requested feedback was not provided. It is possible that this is the same issue as 0001665, which I just fixed in GIT.

dinu

2019-09-06 16:37

reporter   ~0005138

I had some hectic weeks, sorry I couldn't provide details, we just downgraded to 2.7.2; I will test again once it's published on pecl.

Issue History

Date Modified Username Field Change
2019-08-06 18:33 dinu New Issue
2019-08-06 18:38 dinu Note Added: 0005110
2019-08-09 16:12 derick Assigned To => derick
2019-08-09 16:12 derick Status new => feedback
2019-08-09 16:12 derick Note Added: 0005111
2019-09-06 11:26 derick Status feedback => resolved
2019-09-06 11:26 derick Resolution open => unable to reproduce
2019-09-06 11:26 derick Note Added: 0005135
2019-09-06 16:37 dinu Note Added: 0005138