View Issue Details

IDProjectCategoryView StatusLast Update
0001695XdebugInstallationpublic2019-08-23 23:37
ReporterojraskAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityhave not tried
Status resolvedResolutionno change required 
Product Version2.8.0beta1 
Target VersionFixed in Version 
Summary0001695: Compilation fails on LT*_VERSION warnings, m4_ifval error
DescriptionWhen attempting to compile for PHP7.4beta2, there are warnings and errors as follows:

$ sudo ./rebuild.sh
[sudo] password for ojrask:
rm: cannot remove 'configure.in': No such file or directory
Configuring for:
PHP Api Version: 20190529
Zend Module Api No: 20190529
Zend Extension Api No: 320190529
configure.ac:161: warning: LTOPTIONS_VERSION is m4_require'd but not m4_defun'd
build/libtool.m4:61: LT_INIT is expanded from...
build/libtool.m4:99: AC_PROG_LIBTOOL is expanded from...
configure.ac:161: the top level
configure.ac:161: warning: LTSUGAR_VERSION is m4_require'd but not m4_defun'd
build/libtool.m4:61: LT_INIT is expanded from...
build/libtool.m4:99: AC_PROG_LIBTOOL is expanded from...
configure.ac:161: the top level
configure.ac:161: warning: LTVERSION_VERSION is m4_require'd but not m4_defun'd
build/libtool.m4:61: LT_INIT is expanded from...
build/libtool.m4:99: AC_PROG_LIBTOOL is expanded from...
configure.ac:161: the top level
configure.ac:161: warning: LTOBSOLETE_VERSION is m4_require'd but not m4_defun'd
build/libtool.m4:61: LT_INIT is expanded from...
build/libtool.m4:99: AC_PROG_LIBTOOL is expanded from...
configure.ac:161: the top level
configure:5667: error: possibly undefined macro: m4_ifval
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
configure:9136: error: possibly undefined macro: _LT_SET_OPTIONS
configure:9136: error: possibly undefined macro: LT_INIT
Steps To ReproduceClone Xdebug master, attempt to compile against PHP 7.4 beta2 using `rebuild.sh`.
Additional InformationI've installed PHP7.4beta2 through deb.sury.org's Ubuntu PPA.
TagsNo tags attached.
Operating SystemUbuntu 18.04
PHP Version7.4-dev

Activities

ojrask

2019-08-13 10:20

reporter   ~0005116

I tried manual compilation steps, and it fails on `phpize`, with the same error messages.

derick

2019-08-20 09:08

administrator   ~0005119

I would ask the provider of the PHP packages (deb.sury.org's Ubuntu PPA), as I don't believe this is a problem with Xdebug and PHP 7.4. I've been compiling that "just fine" for months.

kmdm

2019-08-23 14:40

reporter   ~0005121

Hi derick,

Do you not see this at all with recent PHP 7.4s?

I see it with oci8 and it seems to be related to the PHP 7.4 build system removing "aclocal".

If I run phpize7.4 I get the errors reported in this bug, if I then run:

$ aclocal
$ autoconf
$ autoheader
$ ./configure ...

It then works fine.

kmdm

2019-08-23 17:51

reporter   ~0005122

Yeah, it's a (Debian) packaging problem. Ignore this.

derick

2019-08-23 23:37

administrator   ~0005123

Okay, thanks for confirming that. I'm closing this issue then.

Issue History

Date Modified Username Field Change
2019-08-13 10:18 ojrask New Issue
2019-08-13 10:20 ojrask Note Added: 0005116
2019-08-20 09:08 derick Assigned To => derick
2019-08-20 09:08 derick Status new => feedback
2019-08-20 09:08 derick Note Added: 0005119
2019-08-23 14:40 kmdm Note Added: 0005121
2019-08-23 17:51 kmdm Note Added: 0005122
2019-08-23 23:37 derick Status feedback => resolved
2019-08-23 23:37 derick Resolution open => no change required
2019-08-23 23:37 derick Note Added: 0005123