View Issue Details

IDProjectCategoryView StatusLast Update
0000170XdebugInstallationpublic2006-05-07 23:03
ReporterFlinkAssigned Toderick 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000170: xdebug.trace_output_dir is always /tmp
DescriptionIt is not possible to change the trace_output_dir.
I have entered into php.ini file and restarted apache:

; XDEBUG 2 PROFILER
;zend_extension="/usr/lib/php/extensions"
xdebug.profiler_enable = 1
xdebug.profiler_output_dir = /var/www/html

However the phpinfo file always shows
xdebug.profiler_output_dir /tmp /tmp
xdebug.profiler_output_name crc32 crc32
Additional Information[root@localhost /]# rpm -qi php-xdebug-2.0.0-1.20060103.2mdk
Name : php-xdebug Relocations: (not relocatable)
Version : 2.0.0 Vendor: Mandriva
Release : 1.20060103.2mdk Build Date: jeu 02 fév 2006 12:56:16 CET
Install Date: sam 25 fév 2006 17:15:28 CET Build Host: n2.mandriva.com
Group : Development/PHP Source RPM: php-xdebug-2.0.0-1.20060103.2mdk.src.rpm
Size : 735112 License: BSD-like
Signature : DSA/SHA1, jeu 02 fév 2006 13:29:57 CET, Key ID dd684d7a26752624
Packager : Iurt the rebuild bot <warly@mandriva.com>


Version 2.0.0rc1-dev
TagsNo tags attached.
Operating System
PHP Version5.1.1

Activities

Flink

2006-02-25 17:39

reporter   ~0000374

Something with the installation seems to be wrong.
When I start a local PHP web application, the no file starting with "cachegrind.out." can be found in /tmp

What can be wrong here?

derick

2006-02-25 17:47

administrator   ~0000376

This line will never work. Firstly it is commented out, and secondly it misses the "xdebug.so" at the end... now you're trying to load an directory as an extension.
;zend_extension="/usr/lib/php/extensions".

Flink

2006-02-25 19:16

reporter   ~0000379

The additions should have been made automatically during the installation with the Mandriva Control Center. So if this is missing this is a bug with Mandriva Linux.

; XDEBUG 2 PROFILER
zend_extension="/usr/lib/php/extensions/xdebug.so"
xdebug.profiler_enable = 1
xdebug.profiler_output_dir = /var/www/html


There is however no difference with these entries in /etc/php.ini
No file is created in /var/www/html or /tmp.

derick

2006-05-07 23:03

administrator   ~0000405

If phpinfo() output doesn't show the correct settings then it's definitely not a problem with Xdebug. Check your installation first.

Issue History

Date Modified Username Field Change
2006-02-25 17:31 Flink New Issue
2006-02-25 17:39 Flink Note Added: 0000374
2006-02-25 17:47 derick Note Added: 0000376
2006-02-25 17:47 derick Status new => feedback
2006-02-25 17:47 derick Additional Information Updated
2006-02-25 19:16 Flink Note Added: 0000379
2006-05-07 23:03 derick Status feedback => resolved
2006-05-07 23:03 derick Resolution open => unable to reproduce
2006-05-07 23:03 derick Assigned To => derick
2006-05-07 23:03 derick Note Added: 0000405