View Issue Details

IDProjectCategoryView StatusLast Update
0001708XdebugRemote Debuggingpublic2019-10-31 10:44
ReporterSvetlanaZemAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version2.8.0beta2 
Target Version2.8.0devFixed in Version2.8.0 
Summary0001708: Xdebug crashes on evaluating object with properties
Description1) Create a file
```
<?php

class Bar {
    public $baz = 0;
}

$a = new Bar();
echo "!"; // put breakpoint here
```

2) Start debug session and stop on the breakpoint.
3) Try to evaluate `$a`
-> Xdebug crashes.
Additional InformationThe issue isn't reproducible on Xdebug 2.8.0alpha1 but it still exists on the latest Xdebug sources, i.e. master branch with the latest commit = https://github.com/xdebug/xdebug/commit/c2724895b1ce7e8a6a05af15136068602f81c8b9
Tagscrash, PHPStorm
Operating System
PHP Version7.3.5-7.3.9

Activities

SvetlanaZem

2019-10-01 21:41

reporter  

xdebug-2.8beta2.log (30,298 bytes)

cgsmith

2019-10-01 21:53

reporter   ~0005158

Link to JetBrains issue tracker: https://youtrack.jetbrains.com/issue/WI-48177

derick

2019-10-07 14:29

administrator   ~0005165

Fixed in GitHub for 2.8.0RC1

manzwebdesigns

2019-10-11 03:17

reporter   ~0005170

Sorry it took me so long, but it looks like it is fixed for me! Thanks so much! :D

Issue History

Date Modified Username Field Change
2019-10-01 21:41 SvetlanaZem New Issue
2019-10-01 21:41 SvetlanaZem Tag Attached: crash
2019-10-01 21:41 SvetlanaZem Tag Attached: PHPStorm
2019-10-01 21:41 SvetlanaZem File Added: xdebug-2.8beta2.log
2019-10-01 21:53 cgsmith Note Added: 0005158
2019-10-07 14:29 derick Assigned To => derick
2019-10-07 14:29 derick Status new => closed
2019-10-07 14:29 derick Resolution open => fixed
2019-10-07 14:29 derick Fixed in Version => 2.8.0dev
2019-10-07 14:29 derick Note Added: 0005165
2019-10-07 14:29 derick Target Version => 2.8.0dev
2019-10-07 14:29 derick Description Updated View Revisions
2019-10-11 03:17 manzwebdesigns Note Added: 0005170
2019-10-31 10:44 derick Fixed in Version 2.8.0dev => 2.8.0