View Issue Details

IDProjectCategoryView StatusLast Update
0001769XdebugStep Debuggingpublic2020-04-22 16:39
ReportersavemetenminutesAssigned Toderick 
PriorityurgentSeverityblockReproducibilitysometimes
Status resolvedResolutionunable to reproduce 
Product Version2.9.3 
Target VersionFixed in Version 
Summary0001769: Some breakpoints cause the session to break on the next line
DescriptionThe title explains the issue clearly.
TagsNo tags attached.
Operating System
PHP Version7.4.0-7.4.4

Activities

savemetenminutes

2020-03-23 02:47

reporter  

savemetenminutes

2020-03-23 02:50

reporter   ~0005327

The first couple of times I tried to submit/report this issue the website showed an error message saying something along the lines of "Invalid Secutiry Marker" (translated). All of my input was lost so I decided to create the issue with minimal info first and then add information afterwards to make sure I don't have to type out all of the info repeatedly.

savemetenminutes

2020-03-23 02:56

reporter   ~0005328

The issue does not seem to occur with Xdebug vesion 2.8.1. Also after enabling 2.8.1 and after that reenabling 2.9.3 the issue happened at other breakpoints.

The image file I've attached in the main section of the bug report demonstrates clearly what happens.

I should mention that I'm using Xdebug through its PhpStorm integration but changing to different PhpStorm versions (years apart) makes no difference.

I understand that reproducing/fixing this issue might be difficult but it does not seem to happen with Xdebug version 2.8.1. Hopefully others can provide more input. My best guess by far is that it might have to do with the breakpoint resolve feature introduced with Xdebug 2.8.

derick

2020-03-23 11:07

administrator   ~0005330

Please follow the instructions on how to report a bug as is described here: https://xdebug.org/reporting-bugs

In particular, the section on "Step Debugger Bugs" at https://xdebug.org/reporting-bugs#step-debugger — it is vital that I can reproduce this myself.

derick

2020-04-16 15:29

administrator   ~0005394

Hi,

I've asked for follow up information three weeks ago. If this does not get provided soon, I will close this ticket out.

cheers,
Derick

savemetenminutes

2020-04-16 15:46

reporter   ~0005396

Hi,

sorry for the delayed response. I will follow up on this before Tuesday next week.

Best regards,
Milen

savemetenminutes

2020-04-20 16:52

reporter   ~0005398

Go ahead and close this. Currently I have no time to test and evaluate this. When I have spare time I will provide the required data and it may be reopened.

derick

2020-04-22 16:39

administrator   ~0005401

OK. Thanks.

Please open a new issue with the new information, as this bug system doesn't allow you to reopen a closed bug.

cheers,
Derick

Issue History

Date Modified Username Field Change
2020-03-23 02:47 savemetenminutes New Issue
2020-03-23 02:47 savemetenminutes File Added: Annotation 2020-03-23 012137.png
2020-03-23 02:50 savemetenminutes Note Added: 0005327
2020-03-23 02:56 savemetenminutes Note Added: 0005328
2020-03-23 11:07 derick Assigned To => derick
2020-03-23 11:07 derick Status new => feedback
2020-03-23 11:07 derick Note Added: 0005330
2020-04-16 15:29 derick Note Added: 0005394
2020-04-16 15:46 savemetenminutes Note Added: 0005396
2020-04-16 15:46 savemetenminutes Status feedback => assigned
2020-04-20 16:52 savemetenminutes Note Added: 0005398
2020-04-22 16:39 derick Status assigned => resolved
2020-04-22 16:39 derick Resolution open => unable to reproduce
2020-04-22 16:39 derick Note Added: 0005401