View Issue Details

IDProjectCategoryView StatusLast Update
0001780XdebugStep Debuggingpublic2020-04-29 13:27
ReporterTom YeagerAssigned Toderick 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Product Version2.9.5 
Target VersionFixed in Version 
Summary0001780: PHP / Netbeans works fine but unable to start a debugging session
DescriptionWaiting for Connection - Never Connects
Will not add information to the debug file.
Steps To ReproduceInitial installation.
Download RawCap to obtain results from the loopback address. Creates dumpfile.pcap that can be analyzed by WireShark. Netbeans connects to XDebug, Netbeans sends proxyin it -p 9001 -k netbeans -xdebug -m0. Next push sends only data 0.
Additional InformationUsing 9001 instead of 9000 to avoid fastCGI. Set 9001 in three places.
TagsNo tags attached.
Operating SystemWindows 10
PHP Version7.4.0-7.4.4

Activities

Tom Yeager

2020-04-28 23:54

reporter  

dumpfile.pcap (1,271 bytes)
php.ini (74,578 bytes)
Capture.JPG (167,656 bytes)
Capture.JPG (167,656 bytes)

derick

2020-04-29 13:27

administrator   ~0005404

Hi,

I am not sure why you're using a proxy to begin with here. When you say "Netbeans sends proxyinit -p 9001 -k netbeans -xdebug -m0", that's fine, but in normal cases, Xdebug needs to initiate the connection **to** Netbeans. Unless you have a complex set-up, you don't need a proxy. I think what is happening is that Netbeans is in listening mode, and then it connects *to itself* because you have a proxy configured. Don't use the proxy, and instead let Xdebug connect to Netbeans (on port 9001).

You'll likely get no log file, because you didn't configure an absolute path for xdebug.remote_log. Make it c:\tmp\xdebug.log (and make sure the webserver/xdebug can write there), and that should work.

As this is not a bug (but rather a support query), I'll close this report. For support, please send your inquires to https://stackoverflow.com/questions/tagged/xdebug (or have a look at https://xdebug.org/support).

cheers,
Derick

Issue History

Date Modified Username Field Change
2020-04-28 23:54 Tom Yeager New Issue
2020-04-28 23:54 Tom Yeager File Added: dumpfile.pcap
2020-04-28 23:54 Tom Yeager File Added: php.ini
2020-04-28 23:54 Tom Yeager File Added: Capture.JPG
2020-04-29 13:27 derick Assigned To => derick
2020-04-29 13:27 derick Status new => resolved
2020-04-29 13:27 derick Resolution open => no change required
2020-04-29 13:27 derick Note Added: 0005404