View Issue Details

IDProjectCategoryView StatusLast Update
0001839XdebugStep Debuggingpublic2020-09-16 14:08
Reporterderick Assigned Toderick  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version2.9.6 
Target Version2.9.7Fixed in Version2.9.7 
Summary0001839: Add keepalive options to debugging socket
DescriptionSometimes the debugger doesn't realise that the client side is down, for example due to a broken VPN connection. But if that happens, the debugger still ties up a connection/Apache process.
TagsNo tags attached.
Operating System
PHP Version7.4.0-7.4.4

Activities

derick

2020-09-16 14:08

administrator   ~0005459

Fixed through https://github.com/xdebug/xdebug/pull/641

Issue History

Date Modified Username Field Change
2020-08-28 09:07 derick New Issue
2020-08-28 09:07 derick Product Version => 2.9.6
2020-08-28 09:07 derick Target Version => 2.9.7
2020-09-16 14:08 derick Assigned To => derick
2020-09-16 14:08 derick Status new => closed
2020-09-16 14:08 derick Resolution open => fixed
2020-09-16 14:08 derick Fixed in Version => 2.9.7
2020-09-16 14:08 derick Note Added: 0005459