View Issue Details

IDProjectCategoryView StatusLast Update
0001894XdebugStep Debuggingpublic2021-04-27 15:51
Reporterjavijavo29 Assigned Toderick  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version3.0.0RC1 
Target Version3.1dev 
Summary0001894: XDEBUG_SESSION cookie ignored and not sent do dbgProxy
DescriptionI'm trying to use XDEBUG against the official dbgProxy, but is not working.

The cookie XDEBUG_SESSION is set in the browser via "xDebug Helper" for chrome or Firefox.
The cookie arrives to Apache server.
But then the cookie is not sent by Xdebug to the proxy configured, the message has no "idekey" set.

I've tried using XDEBUG_SESSION_START by parameter with similar results

This is the trace from the xdebug log where there is no IDEKEY set at all:
<code>
[36333] Log opened at 2020-11-23 13:28:54.891019
[36333] [Step Debug] INFO: Connecting to configured address/port: 192.168.32.76:9100.
[36333] [Step Debug] INFO: Connected to debugging client: 192.168.32.76:9100 (through xdebug.client_host/xdebug.client_port). :-)
[36333] [Step Debug] -> <init xmlns="urn:debugger_protocol_v1" xmlns:xdebug="https://xdebug.org/dbgp/xdebug" fileuri="file:///media/demo.php" language="PHP" xdebug:language_version="7.4.8" protocol_version="1.0" appid="36333"><engine version="3.0.0RC1"><![CDATA[Xdebug]]></engine><author><![CDATA[Derick Rethans]]></author><url><![CDATA[https://xdebug.org]]></url><copyright><![CDATA[Copyright (c) 2002-2020 by Derick Rethans]]></copyright></init>

[36333] [Step Debug] -> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="https://xdebug.org/dbgp/xdebug" status="stopping" reason="ok"></response>

[36333] Log closed at 2020-11-23 13:28:55.409146
</code>


From the dbgProxy log:
<code>
dbgProxy -i 192.168.32.76:9101 -s 192.168.32.76:9100
Xdebug DBGp proxy (0.3)
Copyright 2020 by Derick Rethans
13:28:36.392 [warn] [SSL] The 'certs/fullchain.pem' file could not be found, not enabling SSL listeners
13:28:36.393 [info] [dbgpProxy] Proxy started
13:28:36.395 [info] [server] Started server server on 192.168.32.76:9100
13:28:36.395 [info] [server] Started client server on 192.168.32.76:9101
13:28:52.976 [info] [server] Start new server connection from 192.168.32.78:10980
13:28:52.978 [warn] [server] Handler response error: Both IDE Key and Cloud User are unset
13:28:52.978 [info] [server] Closing server connection from 192.168.32.78:10980

</code>


In version of xdebug 2.9.8, we have a similar proble but the IDEKEY was sent with a default of the apache user, ignoring the XDEBUG_SESSION cookie as well.

Many thanks
Additional InformationPHP 7.4.1 (cli) (built: Mar 16 2020 17:33:26) ( NTS )
Copyright (c) The PHP Group
Zend Engine v3.4.0, Copyright (c) Zend Technologies
    with Xdebug v3.0.0RC1, Copyright (c) 2002-2020, by Derick Rethans


TagsNo tags attached.
Operating SystemCentOS Linux release 7.7.1908 (Core)
PHP Version7.4.0-7.4.4

Activities

derick

2021-03-15 14:15

administrator   ~0005711

Could you try this with the latest version (3.0.3)? I am trying to reproduce this, but the proxy sees the IDE key (derick-test in my case), just fine:

<code>
2021-03-15 14:14:01.789 [info] [server] Start new server connection from 127.0.0.1:46538
2021-03-15 14:14:01.789 [info] [proxy-client] [derick-test] Could not find IDE connection for IDE Key 'derick-test'
2021-03-15 14:14:01.790 [warn] [server] Handler response error: Error reading response: Error reading length: EOF
</code>

It didn't connect though, because I've no IDE listening.

javijavo29

2021-03-31 07:49

reporter   ~0005819

Hi,

With version 3.0.3 is working perfectly.

Many thanks

derick

2021-04-27 15:51

administrator   ~0005864

OK. Perfect. I'll close this out then.

Issue History

Date Modified Username Field Change
2020-11-23 13:43 javijavo29 New Issue
2020-11-27 11:59 derick Assigned To => derick
2020-11-27 11:59 derick Status new => acknowledged
2020-11-27 12:01 derick Target Version => 3.0dev
2021-03-15 14:15 derick Status acknowledged => feedback
2021-03-15 14:15 derick Note Added: 0005711
2021-03-15 16:31 derick Target Version 3.0dev => 3.1dev
2021-03-31 07:49 javijavo29 Note Added: 0005819
2021-03-31 07:49 javijavo29 Status feedback => assigned
2021-04-27 15:51 derick Status assigned => closed
2021-04-27 15:51 derick Resolution open => no change required
2021-04-27 15:51 derick Note Added: 0005864