View Issue Details

IDProjectCategoryView StatusLast Update
0001899XdebugStep Debuggingpublic2020-11-27 11:58
Reporterfb@penneo.com Assigned Toderick  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionduplicate 
PlatformdockerOSalpine 
Summary0001899: Segmentation faul when disabling a breaking while session is active
DescriptionI get this when disabling breakpoints:
Program received signal SIGSEGV, Segmentation fault.
0x00007f55e19f762b in free () from /lib/ld-musl-x86_64.so.1
Steps To ReproduceUsing php:7.2-alpine, PHP 7.2.34, and PhpStorm 2020.2.4 with this config:
xdebug.mode = debug
xdebug.client_host = dev.penneo.com
xdebug.client_port = 9000
xdebug.log = /tmp/xdebug.log

Steps:
- set breakpoint
- run script
- wait for breakpoint to be reached
- remove breakpoint
TagsNo tags attached.
Operating System
PHP Version7.2.30-7.2.39

Relationships

duplicate of 0001897 closedderick Crash when removing a breakpoint 

Activities

derick

2020-11-27 11:58

administrator   ~0005548

This is a duplicate of 0001897, and I'm in the process of fixing it right now.

Issue History

Date Modified Username Field Change
2020-11-27 11:45 fb@penneo.com New Issue
2020-11-27 11:58 derick Assigned To => derick
2020-11-27 11:58 derick Status new => resolved
2020-11-27 11:58 derick Resolution open => duplicate
2020-11-27 11:58 derick Note Added: 0005548
2020-11-27 11:58 derick Relationship added duplicate of 0001897