View Issue Details

IDProjectCategoryView StatusLast Update
0001915XdebugUncategorizedpublic2020-12-18 16:28
ReporterAndreKR Assigned Toderick  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version3.0.1 
Target Version3.0devFixed in Version3.0.2 
Summary0001915: Debugger should only start with XDEBUG_SESSION and not XDEBUG_PROFILE
DescriptionIn Xdebug 2 my config was:

; Do not show Xdebug "enhanced" error messages:
xdebug.default_enable = 0

; Start debugging when XDEBUG_SESSION cookie comes in:
xdebug.remote_enable=1

; Start a profile when XDEBUG_PROFILE cookie comes in:
xdebug.profiler_enable_trigger = 1

I believe in Xdebug 3 this translates to:

xdebug.mode = debug,profile
xdebug.start_with_request=trigger

However, with this config, the cookie XDEBUG_PROFILE starts debugging, which is of course not the desired behavior.
Additional InformationPHP php-7.3.1-nts-Win32-VC15-x64
Xdebug php_xdebug-3.0.1-7.3-vc15-nts-x86_64
TagsNo tags attached.
Operating System
PHP Version7.3.0-7.3.1

Activities

mdafert

2020-12-18 14:15

reporter   ~0005599

I have the same issue, as I would also like to selectively enable modes (without having to edit my configuration and restarting apache).

derick

2020-12-18 16:28

administrator   ~0005602

This is fixed on GitHub for Xdebug 3.0.2 now.

I would like to mention that having both the debugger and profiler on at the same time will result in less accurate profiles due to the overhead that having the debugger enabled will cause. This overhead is there whether the debugger is activated (through the trigger) or not. I would not advice you to have the debugger as part of "xdebug.mode" in case you want accurate profiles.

cheers,
Derick

Issue History

Date Modified Username Field Change
2020-12-11 17:11 AndreKR New Issue
2020-12-18 14:15 mdafert Note Added: 0005599
2020-12-18 16:09 derick Status new => assigned
2020-12-18 16:09 derick Target Version => 3.0dev
2020-12-18 16:09 derick Summary Function specific trigger XDEBUG_PROFILE not working => Debugger should only start with XDEBUG_SESSION and not XDEBUG_PROFILE
2020-12-18 16:28 derick Assigned To => derick
2020-12-18 16:28 derick Status assigned => closed
2020-12-18 16:28 derick Resolution open => fixed
2020-12-18 16:28 derick Fixed in Version => 3.0.2
2020-12-18 16:28 derick Note Added: 0005602