View Issue Details

IDProjectCategoryView StatusLast Update
0001918XdebugProfilingpublic2020-12-18 13:49
Reporterllaville Assigned Toderick  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.0.1 
Target Version3.0devFixed in Version3.0.2 
Summary0001918: Warn if PHP's Garbage Collection is disabled in gc_stats mode
DescriptionI've tried the xdebug.mode = gcstats and got an empty report

    Garbage Collection Report
    version: 1
    creator: xdebug 3.0.1 (PHP 7.3.25)

    Collected | Efficiency% | Duration | Memory Before | Memory After | Reduction% | Function
    ----------+-------------+----------+---------------+--------------+------------+---------


The reason is : I've a gc_disable(); statement in my CLI script !

It will be pretty good if we have a warning about this status to avoid loosing time to search where it come from. Thanks
TagsNo tags attached.
Operating System
PHP Version7.3.20-7.3.29

Activities

derick

2020-12-18 13:25

administrator   ~0005597

https://github.com/xdebug/xdebug/pull/709

derick

2020-12-18 13:49

administrator   ~0005598

This is fixed for Xdebug 3.0.2, but only for PHP 7.3 and later (due to limitations in PHP). If GC is not enabled at either the start of a request or the end, Xdebug will send a warning to PHP's error log, and Xdebug's diagnostics log.

Issue History

Date Modified Username Field Change
2020-12-18 09:56 llaville New Issue
2020-12-18 13:24 derick Status new => assigned
2020-12-18 13:24 derick Target Version => 3.0dev
2020-12-18 13:24 derick Summary Empty Garbage Collection Report without warnings => Warn if PHP's Garbage Collection is disabled in gc_stats mode
2020-12-18 13:24 derick Description Updated
2020-12-18 13:25 derick Note Added: 0005597
2020-12-18 13:49 derick Assigned To => derick
2020-12-18 13:49 derick Status assigned => closed
2020-12-18 13:49 derick Resolution open => fixed
2020-12-18 13:49 derick Fixed in Version => 3.0.2
2020-12-18 13:49 derick Note Added: 0005598