View Issue Details

IDProjectCategoryView StatusLast Update
0001923XdebugStep Debuggingpublic2021-01-04 00:46
Reportervardan Assigned Toderick  
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version3.0.1 
Summary0001923: CLI session starts ignoring is there XDEBUG_SESSION env. variable
DescriptionI've set up the following env. variables:
- XDEBUG_CONFIG=client_host=docker.host.internal client_port=9003 idekey=PHPSTORM start_with_request=trigger
- XDEBUG_MODE=develop,coverage,debug
- XDEBUG_SESSION=1

Whether or not there is XDEBUG_SESSION variable exists in the environment, I got XDEBUG debugging session started and connect to IDE.

What is more interesting is that when I unset the XDEBUG_MODE env variable or when is not set up (present) initially, XDEBUG session does not start up totally. Thus, XDEBUG_MODE when it is set up controlling XDEGBUG session regardlessly of XDEBUG_SESSION existences in the environment.
Steps To Reproduce1) Set up env variables:
- XDEBUG_CONFIG=client_host=docker.host.internal client_port=9003 idekey=PHPSTORM start_with_request=trigger
- XDEBUG_MODE=develop,coverage,debug
- XDEBUG_SESSION=1
2) Run some PHP CLI code and debugger will start
3) unset XDEBUG_SESSION and run some PHP CLI code and debugger will start
4) unset XDEBUG_MODE and run some PHP CLI code debugger will not start
TagsNo tags attached.
Operating SystemUbuntu 20.04.1 LTS
PHP Version7.4.10-7.4.19

Relationships

duplicate of 0001921 closedderick Xdebug does not start step debugging if start_with_request=trigger 

Activities

derick

2020-12-30 12:40

administrator   ~0005626

What is the output of the following:

XDEBUG_CONFIG="client_host=docker.host.internal client_port=9003 idekey=PHPSTORM start_with_request=trigger" XDEBUG_MODE="develop,coverage,debug" XDEBUG_SESSION=1 php -r "echo ini_get('variables_order');"

derick

2021-01-04 00:46

administrator   ~0005633

No feedback provided, and I believe this is a duplicate of 0001921.

Issue History

Date Modified Username Field Change
2020-12-27 20:10 vardan New Issue
2020-12-30 12:40 derick Assigned To => derick
2020-12-30 12:40 derick Status new => feedback
2020-12-30 12:40 derick Note Added: 0005626
2021-01-04 00:46 derick Status feedback => closed
2021-01-04 00:46 derick Resolution open => duplicate
2021-01-04 00:46 derick Note Added: 0005633
2021-01-04 00:46 derick Relationship added duplicate of 0001921