View Issue Details

IDProjectCategoryView StatusLast Update
0001929XdebugInstallationpublic2021-01-20 11:41
Reporterroberto Assigned Toderick  
Status resolvedResolutionno change required 
PlatformlinuxOSubuntu 20.04OS Versionphp 7.3 / 7.4
Product Version3.0.1 
Summary0001929: xdebug notwork
DescriptionTrouble with last version of xdebug on ubuntu 20.04.
I tried in two machines with same S.O. (ubuntu 20.04), trying using php 7.3, 7.4.
I tried compiling directly xdebug on the machine (as i used to do successfully in past), o trying installing xdebug with pecl.
But when i tried to start debugging a php file from netbeans IDE, it didnt work.
(i tried very much different configurations in php.ini), but it never worked.
my last proof was installing only php7.3 and compiling xdebug, pushing in /usr/lib/php/20180731 directory.
but it didn't worked.
Then I copied from another machine with ubuntu 19.10 (xdebug compiled locally in this machine) and now, whit this, it WORKED.

The not working have dim: 2427048 byte

I attach the two files.

The working is: 1920360 byte

This trouble happened two different times, both of them on ubuntu 20.04 with last xdebug version.
TagsXDEBUG installation ubuntu 20.04
Operating Systemubuntu 20.04
PHP Version7.3.2-7.3.4



2021-01-20 11:41

administrator   ~0005643

This seems unlikely a problem with Xdebug itself, as for hundreds of others it works. If you need support, please reach out through StackOverflow:

Issue History

Date Modified Username Field Change
2021-01-02 01:03 roberto New Issue
2021-01-02 01:03 roberto Tag Attached: XDEBUG installation ubuntu 20.04
2021-01-20 11:41 derick Assigned To => derick
2021-01-20 11:41 derick Status new => resolved
2021-01-20 11:41 derick Resolution open => no change required
2021-01-20 11:41 derick Note Added: 0005643