View Issue Details

IDProjectCategoryView StatusLast Update
0001935XdebugStep Debuggingpublic2021-02-18 12:08
Reportertomjn Assigned Toderick  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionsuspended 
PlatformallOSallOS Versionall
Product Version3.0.2 
Summary0001935: Failure to connect logs to the PHP error log
DescriptionWhen Xdebug cannot connect to the debugger, it prints to the error log. While some may consider this useful for new users who need help, I have a number of users and use cases for which this is highly undesirable and problematic.
Steps To ReproduceRun Xdebug with debug mode but without running a step debugger
Additional InformationI understand that this is intended for new users who might have trouble connecting, but I am not a new user. I don't need the training wheels, and it's actively causing issues as well as a support burden.

Tutorials and pop up tips in programs can be turned off, why can't this?

Additionally, sometimes Xdebug tells me it can't connect, and I say "yes, I know", I don't just have the step debugger running, I have development aids and coverage turned on too.

There are also situations where Xdebug is configured in multiple modes, during which a debugger is not listening but features of Xdebug are still being used

Additionally, my current work project has a shared staging environment for a development branch which we can run Xdebug sessions on, theoretically this could generate these warnings when the site is serving pages to other users

While I disagree with the feature, at least give us a way to turn it off
TagsNo tags attached.
Operating Systemall
PHP Version7.3.20-7.3.29

Relationships

has duplicate 0001936 closedderick Redundant "Could not connect to debugging client 

Activities

tomjn

2021-01-20 12:57

reporter   ~0005646

I understand the reason it's there, and I'm not asking for it to be removed, or even turned off by default.

But right now it's forced on all users, not just new users.

Maybe I forgot to start the debugging session? Maybe my IDE crashed, or updated while the browser app hit endpoints in the background? Maybe I forgot Xdebug was activated? Either way now my error log has been filibustered with messages. What if my app has a heart beat ping that pokes PHP that gets left on over night and I come back in the morning to thousands of "could not connect to debugger" type messages?

royho

2021-01-20 13:14

reporter   ~0005647

I am also seeing these errors littering my PHP logs. This was not the case prior to version 3.0. There needs to be a way to turn these logs off via config or something.

marveloo

2021-01-20 14:04

reporter   ~0005648

It seems that I have just reported a duplicate issue: https://bugs.xdebug.org/view.php?id=1936

marveloo

2021-01-20 14:19

reporter   ~0005649

As a temporary solution, I guess we can set xdebug.log_level=0, however this probably will completely get rid of xdebug error messages. On the other hand, as long as xdebug works fine, this might not be an issue.

derick

2021-02-18 12:05

administrator   ~0005677

This is not a bug, and henceforth I will be closing this bug report.

For Xdebug 3.1 I will consider not showing this message, provided that the xdebug.log setting points to an active log file (ie., one that can be written to).

derick

2021-02-18 12:06

administrator   ~0005678

https://bugs.xdebug.org/view.php?id=1948

tomjn

2021-02-18 12:08

reporter   ~0005680

I'm happy with that suggestion, we can set up documentation and even automate showing messages to users in dashboards from the xdebug log with that logic. Is there a ticket number we can track? I'd be keen to lend some momentum and see if I can gather testers

tomjn

2021-02-18 12:08

reporter   ~0005681

Argh I spoke too soon :)

Issue History

Date Modified Username Field Change
2021-01-20 12:52 tomjn New Issue
2021-01-20 12:57 tomjn Note Added: 0005646
2021-01-20 13:14 royho Note Added: 0005647
2021-01-20 14:04 marveloo Note Added: 0005648
2021-01-20 14:19 marveloo Note Added: 0005649
2021-01-23 11:44 derick Relationship added has duplicate 0001936
2021-02-18 12:05 derick Assigned To => derick
2021-02-18 12:05 derick Status new => resolved
2021-02-18 12:05 derick Resolution open => suspended
2021-02-18 12:05 derick Note Added: 0005677
2021-02-18 12:06 derick Note Added: 0005678
2021-02-18 12:08 tomjn Note Added: 0005680
2021-02-18 12:08 tomjn Note Added: 0005681