View Issue Details

IDProjectCategoryView StatusLast Update
0001936XdebugStep Debuggingpublic2021-02-18 12:07
Reportermarveloo Assigned Toderick  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version3.0.2 
Summary0001936: Redundant "Could not connect to debugging client
DescriptionWhen I use xdebug.start_with_request=yes and my debugger client is NOT in use, my error log is constantly getting flooded with the following error:

[Tue Jan 19 21:12:13.035835 2021] [php:notice] [pid 53] [client ::1:53618] Xdebug: [Step Debug] Could not connect to debugging client. Tried: localhost:9003 (through xdebug.client_host/xdebug.client_port) :-(


While the error message itself is correct because my debugging client is not listening for connections, however I consider this error undesired when xdebug.start_with_request is set to "yes", because with this option set to yes I am completely aware that most of the time Xdebug will not be able to connect to the debugging client, because step debugging is only a small part of all the time spent coding.

Moreover, it causes third party apps and tools to throw errors only because they use shared php configuration. For instance I use stderr to log errors of CLI scripts, and each time I run composer I get this error. I know I can work around this by using triggers, but to my understanding xdebug.start_with_request=yes is intended for those lazy developers who are too lazy deal with triggers and who things that just work.

With all of the above in mind, I suggest that Xdebug should not produce this error when xdebug.start_with_request is set to "yes". Nevertheless I acknowledge that this error message might be useful when using triggers, because when we try to trigger the debugging process, we do it on purpose and we expect Xdebug to connect to the debugging client. If it fails to connect then it is very clear that something went wrong and therefore the error message makes sense. But this is not the case when xdebug.start_with_request=yes.
Tagserror-messages
Operating SystemUbuntu 20.04 on WSL2
PHP Version8.0.0-8.0.4

Relationships

duplicate of 0001935 resolvedderick Failure to connect logs to the PHP error log 

Activities

derick

2021-01-23 11:44

administrator   ~0005653

Closing this as it is a duplicate of 0001935.

derick

2021-02-18 12:07

administrator   ~0005679

https://bugs.xdebug.org/view.php?id=1948

Issue History

Date Modified Username Field Change
2021-01-20 13:52 marveloo New Issue
2021-01-20 13:52 marveloo Tag Attached: error-messages
2021-01-23 11:44 derick Assigned To => derick
2021-01-23 11:44 derick Status new => closed
2021-01-23 11:44 derick Resolution open => duplicate
2021-01-23 11:44 derick Note Added: 0005653
2021-01-23 11:44 derick Relationship added duplicate of 0001935
2021-02-18 12:07 derick Note Added: 0005679