View Issue Details

IDProjectCategoryView StatusLast Update
0000194XdebugFeature/Change requestpublic2006-10-08 20:28
ReporterdsalisburyAssigned Toderick 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000194: Revert new stack trace HTML to old
DescriptionI've just moved from 1.3.2 to 2.0.0-cvs and the formatting on the stack traces is very different. The old style was a lot easier on the eye so I've patched my local xdebug.c file to use the old style. I think I've covered all the places in the error handler.

I will attach the diff file as a proper attachment if possible...
TagsNo tags attached.
Operating System
PHP Version5.1.2

Activities

dsalisbury

2006-08-06 15:30

reporter   ~0000427

Last edited: 2006-08-06 15:32

Looks like I can't attach a file.

Link to the diff (since tabs and such aren't kept when posting it as a note): http://php4.david-salisbury.co.uk/xdebug.c.diff

edited on: 2006-08-06 16:32

derick

2006-08-19 13:08

administrator   ~0000436

Sorry, but I will not go back to the old format. However, I am open to any other improvements on this and you can try to convince me by showing rendered examples :)

dsalisbury

2006-08-19 19:34

reporter   ~0000444

Derick

I'm interested to know why you won't go back to it.

A couple of suggestions I would make are to change the colors so they don't clash so much (foreground against background, especially on the top row of the table where it prints the error message) and to have the text tyle normal instead of italic.

I might put together some ideas at some point and get back to you on it.

derick

2006-10-08 20:28

administrator   ~0000469

I did some work on the stacktraces, making them more readable. I hope that you are content with the new layout which you can find at: http://derickrethans.nl/pimping_xdebug_stack_traces.php

Issue History

Date Modified Username Field Change
2006-08-06 15:29 dsalisbury New Issue
2006-08-06 15:30 dsalisbury Note Added: 0000427
2006-08-06 15:32 dsalisbury Note Edited: 0000427
2006-08-19 13:08 derick Status new => resolved
2006-08-19 13:08 derick Resolution open => won't fix
2006-08-19 13:08 derick Assigned To => derick
2006-08-19 13:08 derick Note Added: 0000436
2006-08-19 19:34 dsalisbury Status resolved => feedback
2006-08-19 19:34 dsalisbury Resolution won't fix => reopened
2006-08-19 19:34 dsalisbury Note Added: 0000444
2006-10-08 20:28 derick Status feedback => resolved
2006-10-08 20:28 derick Resolution reopened => fixed
2006-10-08 20:28 derick Note Added: 0000469