View Issue Details

IDProjectCategoryView StatusLast Update
0001942XdebugInstallationpublic2021-02-18 11:30
Reporterlumpysimon Assigned Toderick  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Product Version3.0.2 
Summary0001942: Cannot install: 'Make failed' due to 'asm goto' errors on MacOS
DescriptionI cannot get Xdebug to install on MacOS Catalina, with Homebrew, PHP7.4.14, Laravel Valet.

Every time I try 'pecl install xdebug' it gets stuck with 'ERROR: `make' failed' after a number of errors saying 'error: 'asm goto' constructs are not supported yet'.

I've run 'brew update', and made sure that Laravel Valet is at the latest version, and I've tried using sudo for the pecl install command, but all to no avail.
Additional InformationHere's the complete output from the 'pecl install xdebug' command:

downloading xdebug-3.0.2.tgz ...
Starting to download xdebug-3.0.2.tgz (215,816 bytes)
.............................................done: 215,816 bytes
87 source files, building
running: phpize
Configuring for:
PHP Api Version: 20190902
Zend Module Api No: 20190902
Zend Extension Api No: 320190902
building in /private/tmp/pear/temp/pear-build-rootOWDf86/xdebug-3.0.2
running: /private/tmp/pear/temp/xdebug/configure --with-php-config=/usr/local/opt/php@7.4/bin/php-config
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for a sed that does not truncate output... /usr/bin/sed
checking for pkg-config... no
checking for cc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... x86_64-apple-darwin19.6.0
checking host system type... x86_64-apple-darwin19.6.0
checking target system type... x86_64-apple-darwin19.6.0
checking for PHP prefix... /usr/local/Cellar/php@7.4/7.4.14
checking for PHP includes... -I/usr/local/Cellar/php@7.4/7.4.14/include/php -I/usr/local/Cellar/php@7.4/7.4.14/include/php/main -I/usr/local/Cellar/php@7.4/7.4.14/include/php/TSRM -I/usr/local/Cellar/php@7.4/7.4.14/include/php/Zend -I/usr/local/Cellar/php@7.4/7.4.14/include/php/ext -I/usr/local/Cellar/php@7.4/7.4.14/include/php/ext/date/lib
checking for PHP extension directory... /usr/local/Cellar/php@7.4/7.4.14/pecl/20190902
checking for PHP installed headers prefix... /usr/local/Cellar/php@7.4/7.4.14/include/php
checking if debug is enabled... no
checking if zts is enabled... no
checking for gawk... no
checking for nawk... no
checking for awk... awk
checking if awk is broken... no
checking whether to enable Xdebug support... yes, shared
checking whether to enable Xdebug developer build flags... no
checking Check for supported PHP versions... supported (7.4.14)
checking for gettimeofday... yes
checking for clock_gettime... yes
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking netinet/in.h usability... yes
checking netinet/in.h presence... yes
checking for netinet/in.h... yes
checking poll.h usability... yes
checking poll.h presence... yes
checking for poll.h... yes
checking sys/poll.h usability... yes
checking sys/poll.h presence... yes
checking for sys/poll.h... yes
checking for cos in -lm... yes
checking for a sed that does not truncate output... /usr/bin/sed
checking for ld used by cc... /Library/Developer/CommandLineTools/usr/bin/ld
checking if the linker (/Library/Developer/CommandLineTools/usr/bin/ld) is GNU ld... no
checking for /Library/Developer/CommandLineTools/usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognize dependent libraries... pass_all
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking the maximum length of command line arguments... 196608
checking command to parse /usr/bin/nm -B output from cc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking for dsymutil... dsymutil
checking for nmedit... nmedit
checking for -single_module linker flag... yes
checking for -exported_symbols_list linker flag... yes
checking if cc supports -fno-rtti -fno-exceptions... yes
checking for cc option to produce PIC... -fno-common
checking if cc PIC flag -fno-common works... yes
checking if cc static flag -static works... no
checking if cc supports -c -o file.o... yes
checking whether the cc linker (/Library/Developer/CommandLineTools/usr/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... darwin19.6.0 dyld
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no

creating libtool
appending configuration tag "CXX" to libtool
configure: patching config.h.in
configure: creating ./config.status
config.status: creating config.h
running: make
Makefile:228: warning: overriding commands for target `test'
Makefile:132: warning: ignoring old commands for target `test'
/bin/sh /private/tmp/pear/temp/pear-build-rootOWDf86/xdebug-3.0.2/libtool --mode=compile cc -I. -I/private/tmp/pear/temp/xdebug -DPHP_ATOM_INC -I/private/tmp/pear/temp/pear-build-rootOWDf86/xdebug-3.0.2/include -I/private/tmp/pear/temp/pear-build-rootOWDf86/xdebug-3.0.2/main -I/private/tmp/pear/temp/xdebug -I/usr/local/Cellar/php@7.4/7.4.14/include/php -I/usr/local/Cellar/php@7.4/7.4.14/include/php/main -I/usr/local/Cellar/php@7.4/7.4.14/include/php/TSRM -I/usr/local/Cellar/php@7.4/7.4.14/include/php/Zend -I/usr/local/Cellar/php@7.4/7.4.14/include/php/ext -I/usr/local/Cellar/php@7.4/7.4.14/include/php/ext/date/lib -I/private/tmp/pear/temp/xdebug/src -I/private/tmp/pear/temp/pear-build-rootOWDf86/xdebug-3.0.2/src -DHAVE_CONFIG_H -g -O2 -c /private/tmp/pear/temp/xdebug/xdebug.c -o xdebug.lo
mkdir .libs
 cc -I. -I/private/tmp/pear/temp/xdebug -DPHP_ATOM_INC -I/private/tmp/pear/temp/pear-build-rootOWDf86/xdebug-3.0.2/include -I/private/tmp/pear/temp/pear-build-rootOWDf86/xdebug-3.0.2/main -I/private/tmp/pear/temp/xdebug -I/usr/local/Cellar/php@7.4/7.4.14/include/php -I/usr/local/Cellar/php@7.4/7.4.14/include/php/main -I/usr/local/Cellar/php@7.4/7.4.14/include/php/TSRM -I/usr/local/Cellar/php@7.4/7.4.14/include/php/Zend -I/usr/local/Cellar/php@7.4/7.4.14/include/php/ext -I/usr/local/Cellar/php@7.4/7.4.14/include/php/ext/date/lib -I/private/tmp/pear/temp/xdebug/src -I/private/tmp/pear/temp/pear-build-rootOWDf86/xdebug-3.0.2/src -DHAVE_CONFIG_H -g -O2 -c /private/tmp/pear/temp/xdebug/xdebug.c -fno-common -DPIC -o .libs/xdebug.o
In file included from /private/tmp/pear/temp/xdebug/xdebug.c:25:
In file included from /usr/local/Cellar/php@7.4/7.4.14/include/php/main/php.h:33:
In file included from /usr/local/Cellar/php@7.4/7.4.14/include/php/Zend/zend.h:356:
/usr/local/Cellar/php@7.4/7.4.14/include/php/Zend/zend_operators.h:523:10: error: 'asm goto' constructs are not supported yet
        __asm__ goto(
                ^
/usr/local/Cellar/php@7.4/7.4.14/include/php/Zend/zend_operators.h:586:10: error: 'asm goto' constructs are not supported yet
        __asm__ goto(
                ^
/usr/local/Cellar/php@7.4/7.4.14/include/php/Zend/zend_operators.h:656:10: error: 'asm goto' constructs are not supported yet
        __asm__ goto(
                ^
/usr/local/Cellar/php@7.4/7.4.14/include/php/Zend/zend_operators.h:766:10: error: 'asm goto' constructs are not supported yet
        __asm__ goto(
                ^
/private/tmp/pear/temp/xdebug/xdebug.c:150:32: warning: address of array 'new_value->val' will always evaluate to 'true' [-Wpointer-bool-conversion]
        if (!new_value || !new_value->val) {
                          ~~~~~~~~~~~~^~~
/private/tmp/pear/temp/xdebug/xdebug.c:163:32: warning: address of array 'new_value->val' will always evaluate to 'true' [-Wpointer-bool-conversion]
        if (!new_value || !new_value->val) {
                          ~~~~~~~~~~~~^~~
/private/tmp/pear/temp/xdebug/xdebug.c:176:32: warning: address of array 'new_value->val' will always evaluate to 'true' [-Wpointer-bool-conversion]
        if (!new_value || !new_value->val) {
                          ~~~~~~~~~~~~^~~
/private/tmp/pear/temp/xdebug/xdebug.c:192:30: warning: address of array 'new_value->val' will always evaluate to 'true' [-Wpointer-bool-conversion]
        if (new_value && new_value->val && strlen(new_value->val) > 0 && strncmp("This setting", new_value->val, 11) != 0) {
                      ~~ ~~~~~~~~~~~^~~
/private/tmp/pear/temp/xdebug/xdebug.c:207:30: warning: address of array 'new_value->val' will always evaluate to 'true' [-Wpointer-bool-conversion]
        if (new_value && new_value->val && strlen(new_value->val) > 0 && strncmp("This setting", new_value->val, 11) != 0) {
                      ~~ ~~~~~~~~~~~^~~
5 warnings and 4 errors generated.
make: *** [xdebug.lo] Error 1
ERROR: `make' failed
TagsNo tags attached.
Operating SystemMacOS Catalina 10.15.7
PHP Version7.4.10-7.4.19

Activities

derick

2021-02-18 11:30

administrator   ~0005672

This is not a problem with Xdebug, but with PHP, or rather, it is because you're trying to compile Xdebug with a different compiler than your PHP was compiled with.

The PHP issue is https://bugs.php.net/bug.php?id=75951
And https://bugs.php.net/bug.php?id=80607&edit=1 contains a workaround.

Issue History

Date Modified Username Field Change
2021-01-31 17:51 lumpysimon New Issue
2021-02-18 11:30 derick Assigned To => derick
2021-02-18 11:30 derick Status new => resolved
2021-02-18 11:30 derick Resolution open => no change required
2021-02-18 11:30 derick Note Added: 0005672