MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000195XdebugUsage problems (Wrong Results)public2006-08-19 13:102006-10-03 21:09
Reporterorson 
Assigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
StatusresolvedResolutionsuspended 
PlatformWindowsOSXPOS Versionsp2
Product Version2.0.0dev 
Target VersionFixed in Version 
Summary0000195: CLI Error after debgging session
DescriptionI use lastest dev (2.0.0rc1-dev) and PHPEclise custom build from CVS. I can debug, see variables, set break points BUT when session ends allways windows error msg popup :/ error is about: "CLI has encountered a problem and needs to close. We are sorry for the inconvenience." It's annoying :/
Steps To ReproduceEnd debugging session (either click stop or end execution)
Additional Informationwin xp sp2
Apache/2.0.58 (Win32) PHP/5.1.5
2.0.0rc1-dev
TagsNo tags attached.
Operating SystemWindows
PHP Version5.1.2
Attached Files

- Relationships

-  Notes
(0000433)
orson (reporter)
2006-08-19 13:13

I can send you windows stack trace of error if you need it ...
(0000434)
derick (administrator)
2006-08-19 13:51

No need for the windows trace... however the script that you used and the xdebug log (you can generate that with xdebug.remote_log=c:\tmp\xdebug.log) would beuseful providing it is a short script. Are you also sure you're using PHP 5.1.2 and which exact build date of Xdebug did you use?
(0000438)
orson (reporter)
2006-08-19 14:25

Hi

I'm using php 5.1.5 but this version isn't in select ;)
Xdebug version: php-5.1.2 (5_1) bulid: 2006-08-19 10:08:16
if this is php version issue i will try downgrade my version tonight ...
(0000440)
derick (administrator)
2006-08-19 14:34

No, it should be fine... however I can not reproduce this on Linux (and I don't have Windows)... so if you could provide the script and xdebug log I might be able to reproduce it.

I added the new PHP versions to the select box now though.
(0000443)
derick (administrator)
2006-08-19 16:02

I committed a possible fix to CVS. Please grab a new compiled DLL from http://pecl4win.php.net/ext.php/php_xdebug.dll [^] and make sure it is dated *after* "2006-08-19 12:08:16". Please re-open this bug if it does not address the issue.
(0000446)
orson (reporter)
2006-08-20 15:41

nope ... popup still appear ... did you get my email ? yesterday i sent you letter with log, sample script and screenshots ... did you get it ? should i send it again ?
i also notice this in my event log:

Event Type: Error
Event Source: Application Error
Event Category: None
Event ID: 1000
Date: 2006-08-20
Time: 15:37:48
User: N/A
Computer: GRZEGORZ
Description:
Faulting application php.exe, version 5.1.5.5, faulting module unknown, version 0.0.0.0, fault address 0x00fc82a0.
maybe this is strict php issue ?
(0000447)
derick (administrator)
2006-08-20 15:48

Yes, I got your log and test file. I still could not reproduce it with that on Linux though but found another thing that could have been it. But it seems that was not the case. You mentioned you could give me a stack trace on windows - that might be helpful now as look as it looks like something like the trace on http://bugs.php.net/bugs-generating-backtrace-win32.php [^] .
(0000448)
orson (reporter)
2006-08-20 16:11

hmm ... unexpectedly i found workarodund/solution! in phpeclipse i changed php interpreter to php-cgi.php ... now it's working without problems! I allways use php.exe in settings to code inspecting and parse check's and there php.exe works ok ... so you can close this bug :D

ps. about stacktrace: i don't have ms vc++ in home but if you wan't i will try to reproduce this error in my work, there we have vs 6.0 and 2003
(0000467)
derick (administrator)
2006-10-03 21:09

You shouldn't need to do that actually. Please reopen this report when you encounter more problems with it.

- Issue History
Date Modified Username Field Change
2006-08-19 13:10 orson New Issue
2006-08-19 13:13 orson Note Added: 0000433
2006-08-19 13:51 derick Note Added: 0000434
2006-08-19 13:51 derick Status new => feedback
2006-08-19 14:25 orson Note Added: 0000438
2006-08-19 14:34 derick Note Added: 0000440
2006-08-19 16:02 derick Status feedback => closed
2006-08-19 16:02 derick Note Added: 0000443
2006-08-20 15:41 orson Status closed => feedback
2006-08-20 15:41 orson Resolution open => reopened
2006-08-20 15:41 orson Note Added: 0000446
2006-08-20 15:48 derick Note Added: 0000447
2006-08-20 16:11 orson Note Added: 0000448
2006-10-03 21:09 derick Status feedback => resolved
2006-10-03 21:09 derick Resolution reopened => suspended
2006-10-03 21:09 derick Assigned To => derick
2006-10-03 21:09 derick Note Added: 0000467
2016-07-31 13:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 13:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker