View Issue Details

IDProjectCategoryView StatusLast Update
0001954XdebugTracingpublic2021-03-15 11:17
Reporterderick Assigned Toderick  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.0.3 
Target Version3.0devFixed in Version3.0.4 
Summary0001954: Calling xdebug_start_trace without mode including tracing results in a fatal error
DescriptionRunning xdebug_start_trace() when Xdebug's modes don't include tracing results in a fatal error due to that the return type may not be null.
Steps To Reproduce$ php -dxdebug.mode=off -r 'xdebug_start_trace();'

Notice: Functionality is not enabled in Command line code on line 1

Fatal error: Return value of xdebug_start_trace() must be of the type string, null returned in Unknown on line 0
TagsNo tags attached.
Operating System
PHP Version8.0.0-8.0.4

Activities

Issue History

Date Modified Username Field Change
2021-03-14 15:09 derick New Issue
2021-03-15 11:17 derick Assigned To => derick
2021-03-15 11:17 derick Status new => closed
2021-03-15 11:17 derick Resolution open => fixed
2021-03-15 11:17 derick Fixed in Version => 3.0.4
2021-03-15 11:17 derick Note Added: 0005710