View Issue Details

IDProjectCategoryView StatusLast Update
0001962XdebugStep Debuggingpublic2021-08-18 12:26
ReporterEddcapone Assigned Toderick  
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version3.0.3 
Summary0001962: Step debugger takes extremly long to reach breakpoint -
DescriptionI started the step debugger in Netbeans and successfully debugged my code.
After the debug session ended, I reloaded the site without changing anything. Normally the debug session should restart again.
But now the site is taking 5 Minutes and 30 seconds to load. Sometimes it just ignores the breakpoints if it finished loading.

So I restarted the webserver and it works again.
Then I successfully debugged again and after It finished I reloaded the site again to trigger a new step debuggin session,
and the same problem happens and I have to restart my webserver again...

It does not help to stop the xdebug session and restart it, from netbeans.

I can reproduce this again and again. It took me hours to figure out that it is not my fault, but that there is some bug related to xdebug and the webserver.
Additional InformationI am using Apache 2.
The code is on a remote server reachable via VPN.

This is my configuration:

        [xdebug]
        zend_extension='/usr/lib/php/20190902/xdebug.so'
        xdebug.max_nesting_level=128
        ;xdebug.mode=develop
        xdebug.mode=debug
        xdebug.start_with_request=yes
        xdebug.connect_timeout_ms=200
        xdebug.log=/var/log/xdebug/xdebug.log
        xdebug.idekey="netbeans-xdebug"
        xdebug.client_port=9003
        xdebug.client_host=172.16.xxx.xxx <---- set to the company VPN network interface
        ;xdebug.discover_client_host=On
        ;xdebug.force_display_errors=On
        ;xdebug.force_error_reporting=1
TagsNo tags attached.
Operating System
PHP Version7.4.0-7.4.4

Activities

derick

2021-08-06 17:34

administrator   ~0005957

Is this still a problem for you? I certainly can't reproduce this.

Do you have an Xdebug log file that shows all the connection attempts? And what specifically is slow - connecting, or something else?

derick

2021-08-18 12:26

administrator   ~0005989

Can't reproduce, and the requested information wasn't provided. Please open a new issue if this is still a problem, but then with that additional information.

Issue History

Date Modified Username Field Change
2021-04-06 14:08 Eddcapone New Issue
2021-08-06 17:34 derick Assigned To => derick
2021-08-06 17:34 derick Status new => feedback
2021-08-06 17:34 derick Note Added: 0005957
2021-08-18 12:26 derick Status feedback => closed
2021-08-18 12:26 derick Resolution open => unable to reproduce
2021-08-18 12:26 derick Note Added: 0005989