View Issue Details

IDProjectCategoryView StatusLast Update
0001975XdebugStep Debuggingpublic2021-05-19 12:19
ReporterJeremyDunn Assigned Toderick  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version3.0.4 
Summary0001975: always get "time-out connecting to debugging client" when client is not running
Descriptionevery HTTP request when the NetBeans client is *not* connected, gives this error in the PHP error log:

[18-May-2021 08:47:12 America/New_York] Xdebug: [Step Debug] Time-out connecting to debugging client, waited: 200 ms. Tried: localhost:9000 (through xdebug.client_host/xdebug.client_port) :-(

(this appears to be a similar issue to 0001953. Can't comment on that ticket since it's read-only)

tried changing various xdebug settings but cannot stop the errors:
;xdebug.start_with_request=default # no change
;xdebug.start_with_request=trigger # no change
;xdebug.start_with_request=no # suppresses debugging capability
Steps To Reproducestart NetBeans debugger. Connects ok ; everything works as-expected. It will stop at breakpoints, display values, etc.

stop debugging in NetBeans; tail the PHP error log: every HTTP request gives the error; and it's noticeably slower due to 200 ms timeout on each request
Additional Informationxdebug 3.0.4 RC1; PHP 8.0.4; Apache httpd 2.4.47; Windows 10 Pro; NetBeans 12.3
 (x64, thread-safe versions of all)

php.ini config:

[xdebug]
xdebug.log="\path\to\xdebug.log"
xdebug.mode=debug
xdebug.client_host=localhost
xdebug.client_port=9000
xdebug.idekey="netbeans-xdebug"
xdebug.output_dir="\path\to\runtime"
xdebug.var_display_max_depth=20
xdebug.var_display_max_children=-1
xdebug.var_display_max_data=-1
TagsNo tags attached.
Operating SystemWindows 10 Pro
PHP Version8.0.0-8.0.4

Relationships

duplicate of 0001948 closedderick Do not redirect warning and error messages to PHP's error log if an Xdebug log is active 

Activities

JeremyDunn

2021-05-18 13:18

reporter   ~0005876

more information: this problem is only occurring in Firefox; not in Chrome
clearing Firefox cookies for the site *solved* the problem. some kind of leftover configuration ??

closing this ticket since problem is no longer happening. sorry for the noise.

JeremyDunn

2021-05-18 14:30

reporter   ~0005877

actually, the problem recurs in Firefox:
1. clear cookies
2. start step-debugging from Netbeans
3. stop debugging
4. now, every HTTP request gives the error

the problem seems to be the NETBEANS_XDEBUG cookie which is set. If this cookie is remove in FF debugger, the problem goes away.

JeremyDunn

2021-05-18 14:32

reporter   ~0005878

edit: the cookie is named XDEBUG_SESSION, with a value of "netbeans-xdebug" per php.ini config. it's created as soon as debugging starts, probably by NB.

derick

2021-05-19 12:19

administrator   ~0005880

What you describe is expected behaviour. Xdebug will warn when it can not connect to the IDE, and it is instructed to make a debugging session, which includes when that cookie is set. With the upcoming Xdebug 3.1 you can configure Xdebug's log file (with xdebug.log) and that warning will no longer show up in your php error log.

Issue History

Date Modified Username Field Change
2021-05-18 13:06 JeremyDunn New Issue
2021-05-18 13:18 JeremyDunn Note Added: 0005876
2021-05-18 14:30 JeremyDunn Note Added: 0005877
2021-05-18 14:32 JeremyDunn Note Added: 0005878
2021-05-19 12:19 derick Assigned To => derick
2021-05-19 12:19 derick Status new => closed
2021-05-19 12:19 derick Resolution open => duplicate
2021-05-19 12:19 derick Note Added: 0005880
2021-05-19 12:19 derick Relationship added duplicate of 0001948