View Issue Details

IDProjectCategoryView StatusLast Update
0002022XdebugStep Debuggingpublic2021-09-29 17:00
ReporterErnestophel Assigned Toderick  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
PlatformdesktopOSUbuntuOS Version21.04
Product Version3.0.4 
Summary0002022: Stepping only in background (Linux, VSCODE, Devilbox)
DescriptionStep-debugging through the php code is working fine in index.php. As soon as jumping to another file stepping can be continued, but there are no stepping pointers in the other files. VSCODE shows error message "not-existing file ... can not be resolved".

file is existing and path-mapping seems to be correct.

Debug session runs to a normal end when going through continously.
Steps To Reproducestart devilbox. start debug mode in index.php under vscode. open vhost-website in browser.
Debugging will start in index.php. Stepping is ok as long as not leaving this file. After leaving error-message and running in background.
TagsNo tags attached.
Operating SystemKubuntu
PHP Version7.4.0-7.4.4

Activities

Ernestophel

2021-09-24 20:31

reporter   ~0006050

Solved this trying a diffenrent PathMappings in launch.json.

"pathMappings": {
        "/shared/httpd/contao": "${workspaceFolder}/projects/contao"

Before that i had:

"pathMappings": {
        "/shared/httpd/contao/web": "${workspaceFolder}/projects/contao/web"

which allowed mapping of index.php (which is in web/) but not of other files (which are in contao/).

Issue History

Date Modified Username Field Change
2021-09-24 20:01 Ernestophel New Issue
2021-09-24 20:31 Ernestophel Note Added: 0006050
2021-09-29 17:00 derick Assigned To => derick
2021-09-29 17:00 derick Status new => closed
2021-09-29 17:00 derick Resolution open => no change required