MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000203XdebugUsage problems (Wrong Results)public2006-09-30 15:272006-10-03 21:08
ReporterSoul--Reaver 
Assigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionreopened 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0000203: PHP errors with html content processed incorrectly
DescriptionI'm using Apache/2.2.3 (Win32) PHP/5.1.6 Server with Xdebug 2.0.0beta6.

When i don't load xdebug an error in php looks like this:
Warning: gzuncompress() [function.gzuncompress.php]: data error in H:\webserver\htdocs\default\SLG\SLG Comms\includes\classes.inc.php on line 583
With "function.gzuncompress.php" being a hyperlink to the php manual on the php.net website.

The same error with xdebug enabled and loaded:
Warning: gzuncompress() [<a href='http://www.php.net/manual/en/function.gzuncompress.php'>function.gzuncompress.php</a> [^]]: data error in H:\webserver\htdocs\default\SLG\SLG Comms\includes\classes.inc.php on line 583
Followed by the call stack.

As you can see the hyperlink in the error is not processed correctly.
TagsNo tags attached.
Operating SystemWindows XP SP2
PHP Version5.1.5
Attached Files

- Relationships

-  Notes
(0000459)
derick (administrator)
2006-10-02 20:40

This doesn't make sense, because if Xdebug is loaded you should not even get the standard warnings, but something similar to http://xdebug.org/images/xdebug_ss1.jpg [^]

How do you load Xdebug? Can you provide a link to your phpinfo() page perhaps?
(0000460)
derick (administrator)
2006-10-02 20:40

Hmm, I wanted to set it to feedback. Sorry for closing it.
(0000461)
Soul--Reaver (reporter)
2006-10-02 21:21
edited on: 2006-10-02 21:34

here's the phpinfo page. I added the a piece of code to reproduce the error at the top. Also added the same error you generate in the image in your bugnote (at the bottom though because of the fatal error it generates).

<?php
gzuncompress('blaat');

phpinfo();

typo();
?>

http://www.pz.homedns.org:4714/phpinfo.php [^]

Here are the php.ini lines concerning xdebug

[xdebug]
zend_extension_ts="H:\webserver\php\php5\ext\php_xdebug-5.1.2-2.0.0beta6.dll"

xdebug.collect_includes = On
xdebug.trace_output_dir = h:\webserver\tmp

If you need anything else let me know

edited on: 2006-10-02 21:24

edited on: 2006-10-02 21:28

edited on: 2006-10-02 21:33

edited on: 2006-10-02 21:33

edited on: 2006-10-02 21:34
(0000462)
Soul--Reaver (reporter)
2006-10-02 22:23

Here's another example

http://www.pz.homedns.org:4714/xdebug-bug_id-0000203.php [^]

contains:
<?php
gzuncompress('blaat');

xdebug_disable();
echo 'xdebug disabled.';

gzuncompress('blaat');
?>
(0000463)
derick (administrator)
2006-10-03 13:46

Okay, I see the problem now. I'll look if I can fix it.
(0000466)
derick (administrator)
2006-10-03 21:08

Fixed in CVS. Thanks for your report!

- Issue History
Date Modified Username Field Change
2006-09-30 15:27 Soul--Reaver New Issue
2006-10-02 20:40 derick Status new => resolved
2006-10-02 20:40 derick Resolution open => unable to reproduce
2006-10-02 20:40 derick Assigned To => derick
2006-10-02 20:40 derick Note Added: 0000459
2006-10-02 20:40 derick Status resolved => feedback
2006-10-02 20:40 derick Resolution unable to reproduce => reopened
2006-10-02 20:40 derick Note Added: 0000460
2006-10-02 21:21 Soul--Reaver Note Added: 0000461
2006-10-02 21:24 Soul--Reaver Note Edited: 0000461
2006-10-02 21:28 Soul--Reaver Note Edited: 0000461
2006-10-02 21:33 Soul--Reaver Note Edited: 0000461
2006-10-02 21:33 Soul--Reaver Note Edited: 0000461
2006-10-02 21:34 Soul--Reaver Note Edited: 0000461
2006-10-02 22:23 Soul--Reaver Note Added: 0000462
2006-10-03 13:46 derick Note Added: 0000463
2006-10-03 13:46 derick Status feedback => confirmed
2006-10-03 21:08 derick Status confirmed => closed
2006-10-03 21:08 derick Note Added: 0000466
2016-07-31 13:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 13:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker