View Issue Details

IDProjectCategoryView StatusLast Update
0002030XdebugStep Debuggingpublic2021-10-15 13:19
Reporterreaktor Assigned Toderick  
PrioritynormalSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.1.0 
Fixed in Version3.1.1 
Summary0002030: PhpStorm step-debug not working on PHP 8.0.11
DescriptionI faced a problem with Xdebug 3.1.0 TS version not working correctly on latest (or any) version of PhpStorm on XAMPP PHP 8.0.11 TS Windows installation. Whenever something else than just "echo" was hit step-debug seems to silently crash. Switching to 3.0.4 seems to work just fine with same settings.

Details of this issue have been described to a detail at https://intellij-support.jetbrains.com/hc/en-us/community/posts/4407744683922--solved-Xdebug-3-PHP-8-0-11-xdebug-fails-at-variable-?page=1#community_comment_4407821522578

You can also see GIF screen capture of this issue at forum message. I also added this animation as an attachment to this ticket.
TagsNo tags attached.
Operating SystemWindows 10
PHP Version8.0-dev

Activities

reaktor

2021-10-07 08:33

reporter  

derick

2021-10-15 13:14

administrator   ~0006121

I believe this is fixed through: https://github.com/xdebug/xdebug/pull/804 — I'll be making 3.1.1 this afternoon.

Issue History

Date Modified Username Field Change
2021-10-07 08:33 reaktor New Issue
2021-10-07 08:33 reaktor File Added: phpstorm_debugger_problem.gif
2021-10-15 13:14 derick Assigned To => derick
2021-10-15 13:14 derick Status new => closed
2021-10-15 13:14 derick Resolution open => fixed
2021-10-15 13:14 derick Fixed in Version => 3.1dev
2021-10-15 13:14 derick Note Added: 0006121
2021-10-15 13:19 derick Fixed in Version 3.1dev => 3.1.1