View Issue Details

IDProjectCategoryView StatusLast Update
0002087XdebugStep Debuggingpublic2022-08-25 18:16
Reporterderick Assigned Toderick  
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status closedResolutionfixed 
Target Version3.2devFixed in Version3.2.0alpha1 
Summary0002087: Introduce step for the return state and virtual property for return value
Description

This extra step should only trigger if the return value is actually set preferably, or otherwise only if it is not NULL.

This extra step should only occur if the breakpoint_include_return_value protocol feature is enabled with the "step_into" and "step_out" commands.

TagsNo tags attached.
Operating System
PHP Version8.0.10-8.0.19

Activities

derick

2022-05-04 15:56

administrator   ~0006290

https://github.com/xdebug/xdebug/pull/834

nickc

2022-08-25 18:16

reporter   ~0006366

I just tested this with VS Code and it seems to be working well.

However, I wonder if it would be useful to be able to see the return value even when you manually Step Over a function call - the use case being that perhaps you don't really want/need to actually visit/inspect the function, but would like to inspect the $__RETURN_VALUE prior to carrying on with the code. This surely should not be the default behaviour, but perhaps something that could be set manually?

Or, perhaps even better, perhaps there's some way to trigger something like "Step Over and Show Return Value" so that you can generally Step Over normally, but also add the extra step to view the Return Value when desired? If this is too difficult or otherwise not feasible, that's fine.

Issue History

Date Modified Username Field Change
2022-04-27 14:59 derick New Issue
2022-05-04 15:52 derick Description Updated
2022-05-04 15:54 derick Summary Add extra debug step when function exits to be able to show the return value => Introduce step for the return state and virtual property for return value
2022-05-04 15:56 derick Note Added: 0006290
2022-06-06 15:18 derick Assigned To => derick
2022-06-06 15:18 derick Status new => closed
2022-06-06 15:18 derick Resolution open => fixed
2022-06-06 15:18 derick Fixed in Version => 3.2dev
2022-07-20 15:49 derick Fixed in Version 3.2dev => 3.2.0alpha1
2022-08-25 18:16 nickc Note Added: 0006366